SOLVED Fresh Debian 9 FOG server install no database?

  • Installed a fresh copy of Debian 9, GIT, PHP 7.0, and MariaDB. I configured a MySQL root password (mysql -u root -p) and then ran through the FOG project setup. Answered all questions (most default values) and entered the MySQL root password when requested. No errors were generated but, when the installer reached the pause for schema update I find that connection to the management interface fails.

    Pointing a local browser to http://localhost/fog/management displays the message “Database connection unavailable”.

    I checked for a list of MySQL databases and don’t see one named FOG.

    What should I do next to figure out what’s gone wrong?


  • I got it sorted out by mistake (i hit enter to early while trying to enter MariaDBs shell - without a password). I entered a mysql password during installation, but it seems like this didn’t get set in MariaDB. I started MariaDB as root with no password entered and could then change the root passwort to what it was supposed to be.

  • Although this thread is quite old. I have the same problem. The installation ran without hiccups. The mentioned logs don’t show any problems. my MariaDB only contains the root user. @fpuser: Have you found a solution?

  • @tom-elliott for the installer?

  • Senior Developer

    @wayne-workman I believe it’s literally, error_logs

  • @fpuser Check both the installation logs and the apache error logs - the installer does do some PHP stuff and errors from that are in the apache error log. On Debian9 that should be in /var/log/apache2/error.log Also the installer logs would be in your cloned repo of fogproject, inside the bin directory. the installer makes a new directory in there - and for the life of me I can never remember the name of it.

  • Verified password and repeated install on clean OS build a couple times with the same result.

    How do I check the FOGP version?
    I ran the command > git clone

    I’m a complete noob and fully expect that I’ve missed something that would be obvious to others. Sorry about that.

    Thanks for pointing me in the direction of the logs, I’ll check them out and get back to the thread with more specific info.


  • @fpuser Maybe you fat-fingered the password entry? Try again. Also, what version of FOG?
    Also, there would be errors in the installation log. This is in a new directory the installer makes inside the bin directory.