Locations and Snapins



  • Centos 7
    1.5.4

    So the issue we are seeing now is with Locations and Snapins. We only want snapins on 1 storage node as we dont have many and dont want to deal with making sure they are replicated and update correctly.

    When you set a location to image a host, even though the snapin does not exist on the locations node and the snapin definition is the only node it is assigned to, FOG tried to copy from the location node which fails because its not there. How can we fix this issue?

    Tagging @ablohowiak


  • Senior Developer

    @Sebastian-Roth this can be addressed from the location plugin under the fog configuration. Location adds a fog setting for allowing snapins to be downloaded from the host location or the master storage node the snap in resides within.


  • Developer

    @UWPVIOLATOR As I just try to pick up topics that we might have missed in the very busy Summer season I found your post again. Let’s see if we can figure this out and maybe fix it if needed.

    When you set a location to image a host, even though the snapin does not exist on the locations node and the snapin definition is the only node it is assigned to

    I am not sure if I get this right. Can you please be more specific to what your settings are (post pictures of web UI settings) and what exactly you are trying to do.

    I get that you want to keep snapins on only one storage node. Is this because replication is causing an issue for you? We have been working on the replication code and improved it a lot. Unfortunately there is still an issue with snapins in version 1.5.5 but that’s fixed in dev-branch and will be in the next release.

    But if you still want to have snapins only on one of your nodes, should all your clients pull the snapin from that single node?!


Log in to reply
 

500
Online

6.2k
Users

13.6k
Topics

128.1k
Posts