Replicated image not showing up under "List All Images"



  • I have setup image replication. The image files ARE replicating to the other nodes but the image does not show up under “Image Management” > List All Images on the other nodes. If I export images from the master and then import it on the replicated node it then shows. I’m not seeing any errors in the log file.

    here is the transfer log for that image:

    
    --- 
    018-07-10 10:56:58 /images/ubuntu-server18.04/d1.fixed_size_partitions -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.fixed_size_partitions 0-3 2 B/s
    2018-07-10 10:56:59 /images/ubuntu-server18.04/d1.partitions -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.partitions 0-395 140 B/s
    2018-07-10 10:56:59 /images/ubuntu-server18.04/d1.original.swapuuids -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.original.swapuuids 0-0
    2018-07-10 10:56:59 /images/ubuntu-server18.04/d1.minimum.partitions -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.minimum.partitions 0-395 140 B/s
    2018-07-10 10:56:59 /images/ubuntu-server18.04/d1.original.fstypes -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.original.fstypes 0-16 6 B/s
    2018-07-10 10:56:59 /images/ubuntu-server18.04/d1.original.uuids -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.original.uuids 0-174 60 B/s
    2018-07-10 10:56:59 /images/ubuntu-server18.04/d1.mbr -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.mbr 0-17920 5.8 KiB/s
    2018-07-10 10:57:00 /images/ubuntu-server18.04/d1p1.img -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1p1.img 0-67399 18.8 KiB/s
    2018-07-10 10:57:08 /images/ubuntu-server18.04/d1.grub.mbr -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1.grub.mbr 0-1048576 90.1 KiB/s
    2018-07-10 11:39:48 /images/ubuntu-server18.04/d1p2.img -> ftp://fog@192.168.190.94/%2Fimages/ubuntu-server18.04/d1p2.img 0-633091770 240.4 KiB/s
    ---
    


  • @tom-elliott said in Replicated image not showing up under "List All Images":

    If your other node is a server in its own right, then this is to be expected. Images aren’t automatically populated in the database, each one requires a definition to be available. So replicating an image from one server to another is fine, but it doesn’t automatically populate the receiving server with the definition.

    oh, ok thanks.


  • Senior Developer

    If your other node is a server in its own right, then this is to be expected. Images aren’t automatically populated in the database, each one requires a definition to be available. So replicating an image from one server to another is fine, but it doesn’t automatically populate the receiving server with the definition.



  • @quazz this is not a storage node, it is a remote full fog server. I’m just replicating from the master node to it. I’m not sure what you mean by changing the definition of an image either.


  • Moderator

    Storage nodes don’t require image definitions. All they do is provide scalability with image(and snapins I think) deployment.

    It wouldn’t really make sense to be able to change the definition of an image on a storage node, it’s a mirror, supposed to be read only.


Log in to reply
 

432
Online

6.3k
Users

13.7k
Topics

128.9k
Posts