Updating Database Failed following Multicast

  • I am experiencing an issue when multicasting to a number of PC’s.

    The image deploys successfully but stalls at ‘Updating Database’ and eventually fails.

    All PC’s are attempting to do this simultaneously so i’m guessing there is an issue with load on the web or mysql server??

    The web interface becomes unresponsive and i have to shutdown the server and manually reboot the clients to resolve.

    I have checked max_connections on the mysql server and that is set to 151. I am getting this error when multicasting to 20ish or more PC’s. I tested a group of 5 and had no issues.

    FOG Version: 1.5.4
    Ubuntu 16.04

    Any help would be appreciated


  • @george1421 This has resolved the issue. Many thanks for your help.

  • Moderator

    Thank you for the clear picture. The key to the problem is the html code in your picture.

    There are a couple of issues that have come up since 1.5.4 has been released that have been fixed in 1.5.5 (still unreleased at this time).

    1. Roll your FOS kernel back to 4.15.2 to get past the mbr/gpt issue. Make sure you download both the 32 and 64 bit PC kernels (not ARM).
    2. Edit the www.conf file to update/include these settings, then reboot your FOG server. You will need to search your /etc directory for this file because depending on what version of php is installed, it can be in several locations. Use this search to find the file (hopefully only one) find /etc -name www.conf
    pm.max_children  = 35
    pm.max_requests = 2000
    php_admin_value[memory_limit] = 256

    There is another bug in the multicasting code, but it only comes out under a specific circumstances. The error above should be corrected with the updates to the www.conf file. Once you update that file reboot the fog server and test again. There is another timeout value that could come into play, but those setting should remove the timeout.

Log in to reply