Dell Latitude 5490 - Deployment of Win10 LTSB Fails



  • Have some Dell Latitude 5490 (2018 version) laptops to image.

    Via UEFI connected USB DVD-ROM drive, clean install from LTSB 2016 ISO media, audit mode, sysprep /generalize /oobe without issue. Deployment via FOG to the same laptop I built the image on there are no issues and Sysprep without issue.

    On the next Latitude 5490, deleted all references to Windows Boot Manager and deployed the captured imaged.

    On the initial boot, where OOBE should kick in get met with an error window:
    Error – Install Windows

    • Details: The computer restarted unexpectedly or encountered an error. Windows installation cannot proceed. To install Windows, click “OK” to restart the computer and then restart the installation.

  • Moderator

    @restlesshustle As outlined in the wiki page use the setupcomplete.cmd batch file to reenable the service or you can do it in the unattend.xml file in the first login if you have auto admin login set up after oobe finishes.



  • @george1421 I do not believe that I disabled the fog client service, which could be the source of the issue.

    I will recapture and reply.


  • Moderator

    Please understand this is beyond the scope of the FOG Deployment. There is an issue with your reference image that is causing it to reboot unexpectedly during OOBE. If you look in c:\windows\panther or c:\windows\sysprep there should be log files that explain what happened to cause it to reboot. It is a bit of a pain to dig through the log files to find out what caused the unexpected reboot but the answer IS in there.

    -OR-

    If you installed the fog client in your reference image before capturing with fog and did not disable the fog client service as recommended, then it IS FOG indirectly causing this issue. ref: https://wiki.fogproject.org/wiki/index.php/FOG_Client#FOG_Client_with_Sysprep



  • @restlesshustle

    I was able to find a work-around.

    When the error comes up, hit SHIFT+F10.
    From the command prompt, issue a “regedit” and change the following registry key’s value from 1 to 3.
    HKLM\System\Setup\Status\ChildCompletion\Setup.exe

    Reference: https://www.thewindowsclub.com/computer-restarted-unexpectedly-encountered-unexpected-error

    Any idea why I have to do this on every deployment, especially if I sysprep with /generalize and /oobe ?

    Thanks in advance, and hopefully this helps out others who are having similar issues.


 

545
Online

5.4k
Users

12.6k
Topics

118.9k
Posts