• Hi,
    I inherited this fog server from the last sys admin. I have tried to use it to image a machine multiple times with the existing images. It stops in the same spot every time (at 65.75MiB of 21.50GiB, which is 0%), the whole process freezes and I have to hold the power button down to shut down in order to stop it. The machine is a Dell GX620 with WinXP. The image is from a GX620. The one thing I suspect is that there is too much network between the fog server and the machine. From the server, it goes through a cisco switch, through a gigabit fiber transceiver in the switch to another fiber transceiver on another cisco switch, then directly to the dell box. (Actually when I typed this out it turned out to be less network than I thought.) It doesn’t matter which GX620 image I use. It fails at 0%. I have tried other images on other machines as well and have never had success. Any ideas why this is happening? I am new to this. Let me know if more info is needed. Thanks.

  • Hi,

    I have exactly the same problem. I have just reinstalled my fog on Ubuntu 10.04 and im having nothing but grief. Fails at 0% on a GX620 and on a 380 it fails at 4%.

    I have checked all mysql settings and they are correct. I have checked my storage node settings and they are correct.

    I thought moving it to Ubuntu 10.04 would work.

    check out this video of mine



  • Moderator

    Have you been able to image any other GX620’s or other models? Is that successful? Have you run a disk check on the HDD in the GX620 to make sure it’s not a drive issue? Try SeaTools for DOS or make a bootable GParted CD/USB stick and clear the drive.

    If it’s not the drive, then it might be the GX620 wants a different kernel. You can boot a LiveCd version of ubutnu desktop, nfs mount the /images from the FOG server and do a file copy just to see if it’s quicker. If it’s still slow, you might have a network issue. If it’s fast, you probably need a different kernel.

  • Well, only a few months huh? You could type the 1’s and 0’s out faster than that.

    Yeah, it’s under the “Other Information” icon (question mark with circle) along the top. And it’ll be “Kernel Updates” along the left hand side. I believe your Fog server will need an internet connection for it to work right.

    My Fog machines need to stay off the network since they’re running their own DHCP servers. That and they’ve got a Microsoft Forefront thing obliterates any/all Linux related stuff from orbit as “Shareware/Freeware”. So, I’ve never tried that tool. But it’s supposed to be pretty easy to swap kernels with it.

    The wiki details creating a custom kernel with manual instructions if your server can’t talk to the interweb either. You could probably use those instructions to place a kernel you downloaded.

    The weird thing is that it looks like it is working, albeit very slow. I might also be considering that something physical is wrong, maybe on the image storage side?

  • Oh, and thank you Bob for your reply. You’re the only one so far. I looked for a little bit about using a different kernel. I can’t seem to find which kernel(s) are being used now. How do you find that. Is it in the fog web interface?

  • Holy crap, I left the image task running just because I got sidetracked to other things, and I came in this morning, and it was up to 100-something MB, and now it’s up to 219.72! Hmm, at this rate it should be done in a couple months. I can just wait! Ha!

  • Hi Matt,

    Well, I’m sure somebody else will have a better idea than me, but…

    Maybe the mode of the drive ATA vs AHCI in the BIOS on the target?

    Have you tried uploading an image to the Fog server? Does that bit work?

    Another thread mentioned switching to a different fog kernel, maybe a newer or older one would work better?

    Beyond that, my thoughts might be that there could be permissions or authentication issues on the storage, image is corrupted, or maybe a bad cable?

    If it won’t complete the upload either, I might check the permissions/authentication bit.

    If you have additional information on your current Fog setup like OS + version and Fog version + kernel, there are some much smarter people than me who can probably get you in the right direction faster.