CentOS 7 Installation Problems



  • After not being able to get the install to complete on Ubuntu 18 or 16 due to inability to download binaries, I decided to give the CentOS install a shot. While it went better in terms of not having to deal with sourcing some of the required packages that are deprecated, the install is still failing at the
    * Downloading binaries needed.................................Failed!

    I’ve included the error log for the attempted CentOS install.
    0_1530198049150_fog_error_1.5.4.log

    Is there a way that I can download the binaries manually?



  • @mparlette @george1421 Thanks. I’m not sure what the issue was, but I believe it to have been network related. I didn’t realize it initially when I posted but the pings I was doing, showed dropped packets galore (even while some were successful). I’m working my way through the install guide after creating a new VM, and so far it’s looking alright. No packet loss on an initial test ping. We’ll see what happens when I start the FOG installer!

    EDIT:
    SUCCESS!



  • @wanderbread I am not sure what is going on but I was extremely happy with the CentOS 7 install. Make sure to follow the specific install instructions for the flavor. I was able to blow it all away and rebuild the server within a few hours no problems. Good luck.


  • Moderator

    @wanderbread well that may not have been a great test. I can’t ping www.fogproject.org either. But the site is up because I can connect via https.

    @Developers, do you have any idea why the binaries would not be downloading during install? Its happening on both ubuntu and centos distros?





  • @george1421 I’m able to ping google by URL, but not fogproject. However, I am able to ping it by the IP listed.

    [root@localhost ~]# ping google.com
    PING google.com (172.217.8.174) 56(84) bytes of data.
    64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=5 ttl=56 time=8.09 ms
    64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=6 ttl=56 time=8.18 ms
    64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=7 ttl=56 time=8.13 ms
    64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=8 ttl=56 time=8.20 ms
    ^X64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=9 ttl=56 time=8.13 ms
    ^C
    --- google.com ping statistics ---
    9 packets transmitted, 5 received, 44% packet loss, time 8019ms
    rtt min/avg/max/mdev = 8.099/8.152/8.204/0.120 ms
    [root@localhost ~]# ping google.com
    PING google.com (172.217.8.174) 56(84) bytes of data.
    64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=4 ttl=56 time=8.15 ms
    64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=5 ttl=56 time=8.20 ms
    64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=6 ttl=56 time=8.16 ms
    ^X64 bytes from ord37s08-in-f14.1e100.net (172.217.8.174): icmp_seq=7 ttl=56 time=8.20 ms
    ^C
    [root@localhost ~]# ping www.fogproject.org
    PING fogproject.org (162.213.199.177) 56(84) bytes of data.
    ^C
    --- fogproject.org ping statistics ---
    49 packets transmitted, 0 received, 100% packet loss, time 48010ms
    [root@localhost git]# ping 172.217.8.174
    PING 172.217.8.174 (172.217.8.174) 56(84) bytes of data.
    64 bytes from 172.217.8.174: icmp_seq=3 ttl=56 time=8.26 ms
    64 bytes from 172.217.8.174: icmp_seq=4 ttl=56 time=8.13 ms
    64 bytes from 172.217.8.174: icmp_seq=5 ttl=56 time=8.13 ms
    ^C
    --- 172.217.8.174 ping statistics ---
    5 packets transmitted, 3 received, 40% packet loss, time 4002ms
    rtt min/avg/max/mdev = 8.136/8.178/8.262/0.119 ms
    
    

  • Moderator

    @wanderbread What is the default route for the fog server? This may be simply a networking issue .

    You also disabled the centos firewall and set setlinux to permissive didn’t you?



  • @george1421 So this is interesting… I’m able to ping machines on our local network, but I cannot ping www.fogproject.org.
    That said, the machine definitely has internet access (as I am currently posting this from said machine).


  • Moderator

    @wanderbread Can your fog computer ping www.fogproject.org?

    I’m also not seeing anything in the log that states it can’t download the binaries either. I know the binary file goes into the root of the installer directory. Let me see if I can find out where they exist in the fogproject world.



  • @george1421 Thanks for the reply, it has direct access.


  • Moderator

    Does your fog server have direct internet access or is it via a proxy server?


 

423
Online

41.9k
Users

12.5k
Topics

117.6k
Posts