UNSOLVED Boot issue : PXE OK but not Windows 7 after that

  • Hi, I hope I’ve choosen the correct forum (is it a FOG issue ??), but it seems to be related with Windows…

    FOG usually works fine on our LAN.
    But on some new PCs, Windows don’t boot after FOG menu (just a blinking “_” top-left cursor after menu without any keyboard action). I’ve found some similar posts but no solution.
    Note that Windows boots when ethernet cable is disconnected (=> no PXE boot found, so second choice choosen) or when it’s the first choice in BIOS/UEFI, but not when FOG PXE menu is reached and then “first HS boot” (automatically or explicitely) choosen.

    FOG server 1.5.2,
    FOG Client 0.11.16
    PC was Windows 10 pre-installed, and downgraded into Win 7 Pro 64bits.
    1 SSD HD, 3 Partition: 260MiB FAT (EFI System partition) boot flag
    + 128MiB (MicroSoft Reserved partition) msftres flag
    + 67,47MiB NTFS (Win7)
    BIOS/UEFI: Secure Boot disabled, CSM enabled. Many combination tested, but here we are:
    . Boot service control=UEFI and Legacy OPROM
    . Boot from network devices=Legacy only (UEFI driver first tested)
    . Boot from storage devices=UEFI driver first
    . Onboard device config.= Intel PXE Option ROM=ON
    . Boot options #1=IBA CL Slot 00FE v0110, #2=Windows Boot Manager (SATA6G_1…)
    (First for LAN PXE Boot, called UEFI: “IP4 Intel® ethernet connection I219_v” when configured with “UEFI First…”)

    Edit : I think I’ve tried any possibilities about “exit types” like SANBOOT on this host…

    Any idea please ? Thank you !

    PS : please be patient if I’m not enough reactive, because managing our LAN is just a small part of my job, so I’m not often close to a PC…

  • Has there been any progress with this issue. I am having the issue where the “_” flashes but goes no further and I have been searching for a solution for the past 3 days.

    In my case, I am attempting to boot a WinPE Environment to run a 3rd party application.

    I tried both clean boot.wim files from Win7 and Win10, both fail. But when booted from a USB Drive or CD the application boots.

    Everything worked perfectly when I was running 1.5.0 but no longer in 1.5.4.

    Dell PowerEdge 910
    Windows Server 2016

    • DHCP
      ** Option 66 - IP of CentOS 7 Server Running Fog
      ** Option 67 - undionly.kpxe
    • DNS
    • Hyper-V
      ** CentOS 7
      ** Fog 1.5.4
      ** 16 Cores
      ** 128GB Ram

    0_1531514314481_PXE Boot to WinPE boot wim stalls.png

    It will sit here forever.

  • No news… Maybe we could close the subject, even if it is not really “solved”:
    I’ve not found a nice solution, but re-installing Windows 7 from scratch allows a correct boot (FOG client menu, then by default or if choosen Windows. Again, don’t forget the PC was Windows 10 pre-installed, then downgraded to Win7).
    So it look like a specific Windows 10 issue…

  • I’ve tried this, concerning the Win12 part (our DHCP server)

    I’ve associated ipxe.efi with “type 9”. It doesn’t work.
    Does anyone knows if this .efi file used to boot FOG PXE menu, or the next step after this menu when “Boot from hard disk” is choosen (or timeout / default choice) ?
    (For example, on the client EFI partition, there’s a Boot\bootx64.efi file…)

    Have a nice week-end.

  • Thank you for your help.
    I’ve forgotten to precise it, but I think I’ve tried all options without any success (modifying only for this client, not the global parameter)…

  • Moderator

    Not all PCs handle the “Exit type” with grace/in the same way.

    You can change it globally or per client in the FOG settings. Default is sanboot I believe.