Capture/Deploy tasks hang on erasing/saving partition tables.



  • Fresh minimal CentOS 7.5 1804 FOG 1.5.4 server install. Followed instructions on the wiki to the letter to do this install. Even used their partitioning advice. Have been using 1.5.2 extensively with only trivial issues. I am capturing and deploying both Windows 10 and Linux images. During the captures, the process stalls for 5-6 minutes at the “Saving original partition table” function and then eventually continues successfully. During a deploy image session, the process stalls once again for 5-6 minutes at the “Erasing current MBR/GPT Tables” function and again continues successfully. This does not occur with 1.5.2. BTW, this happens whether I upgrade from 1.5.2 -> 1.5.4 or by doing a fresh install.

    Any help would be appreciated.



  • @george1421 Hi George. You’re right. I’ve seen this post while I was searching for my error. I’ll give it a try this afternoon. Thanks


  • Moderator

    @nicolas-t If I remember correctly, some posters have said if they roll back their FOS linux kernel to 4.15.2 that the problem goes away. Can you test this idea? You can get older kernels from here: https://fogproject.org/kernels/



  • @tom-elliott Hi,
    Since I moved to the 1.5.4 version I have nearly the same issue but slightly different.
    Saving MBR/GPT Tables still tooks few seconds but Erasing tooks around 15mn.
    The probleme is the same with the last kernel (4.1.7)
    I’ve noticed you’re aware of this issue, so we’ll be patient until the next release to see if this bug is fixed :)
    Thank you again Tom and all the dev for keeping this great project alive.



  • Sorry Tom, I always read the news information when a new release is out but I don’t recall seeing the note. I apologize for not doing more research. will try the newer kernel to see how that works out.


  • Senior Developer

    https://news.fogproject.org/fog-1-5-4/

    It’s already known about and noted with a work around.

    I’ve also pushed up 4.17 kernel that at least in one case seems to have fixed the delayed saving/erasing element.


 

516
Online

41.6k
Users

12.1k
Topics

114.3k
Posts