Windows 10 Mbr capture fixparts error



  • Fog 1.5.4
    Ubuntu 16.04
    Kernel: 4.15.17-3-pve

    i have a problem to capture a disk with windows 10 1803 with Mbr (no uefi for some older systems with no uefi net boot…). I made a clean install from usb stick (not uefi boot) and got a windows with 2 partions (recover and system partiton). When i try to capture the disk with “single disk - resizeable” i just get the following error every time:

    How can i see more error details? (im new to fog project…)

    (a image capture of win10 with uefi partition works without problems)

    0_1529169335904_20180614_163443.jpg


  • Developer

    @georger Please schedule a debug capture task (like normal but hit the checkbox for debug just before submitting) when you get to the shell please run the following commands:

    gdisk -l /dev/sda
    ...
    fixparts /dev/sda
    ...
    

    The later command will ask you to confirm so you go y ENTER w ENTER y ENTER. Possibly it will print out an error and quit straight away. Take a picture of the screen and post here.



  • It is MBR Partition style, is that a problem?



  • Im not sure, but i think it should be MBR Table for default when you turn off Uefi in Bios. (cant verify before monday). I picked single disk - resizeable (edited above).

    I found this thread: https://forums.fogproject.org/topic/12059/fixparts-missing-1-5-4-win-10 with the same error display.
    But in my case, fixparts should be available cause its working with a uefi win10 on my client (ws01) and also with a VirtualBox Vm without Uefi. This problem is just on my client (ws01) without uefi (i tried multiple new installations with clean shutdown (no energy save)

    Is it possible to find out the exact error in debug mode? Which commands i must enter?


  • Moderator

    Did this disk have / was formatted for GPT? I have not personally seen this error before.

    Also why didn’t you pick single disk resizable or was that a type-o what you posted?


 

407
Online

41.6k
Users

12.1k
Topics

114.4k
Posts