Cannot update location association in group



  • FOG version 1.5.4

    I’m trying to update a group with a location association. Here’s the message I get when I hit “update” after selecting the proper location:

    {“msg”:“Group updated!”,“title”:“Group Update Success”}

    When I go back to that same screen next to “Location” it says " - Please select an option -"

    In other words, it didn’t apply.



  • @tom-elliott Getting one host to work as expected in the group seems to have fixed all my issues. Now the changes I make are sticking after I leave the page. Thanks for your help.


  • Senior Developer

    @kafluke I don’t track printers or snapins so that’s to be . Groups do not store Info to themselves. All groups do is mass update hosts. Text fields and singular set items are tracked to some extent



  • @tom-elliott Great that fixed the location issue. Not to hijack my own thread but in further experimenting with groups I noticed that every printer that I automatically gets added to the group. Also it doesn’t seem to matter what changes I make on the printer tab, nothing is sticking. When I come back to the same tab after trying to remove printers or update settings its all back to defaults again.

    I do have one host assigned to this group so I’m not sure what could be causing this issue.


  • Senior Developer

    @kafluke and there inlies the issue. Groups affect hosts. If you have no hosts no data is stored.



  • @tom-elliott This is my first group. I’m just getting started with groups and just barely made my first one. As of right now there aren’t even any hosts associated with this group. I was just trying to get it ready to start putting hosts in there. I was just going through the various tabs for the group setting each section up and it won’t let me assign a location to this group.


  • Senior Developer

    Can you verify that the hosts do or do not have the location associated in the first place?

    I have said this many times in the past. While I do try to have groups show information that applies to all hosts, this does not mean I’m very good at it. If it finds a single host in the group that doesn’t have the location applied, the whole thing will look like it’s not set. This could, potentially, include “non-real” hosts as they wouldn’t get any information associated to them.

    There’s any number of reasons why this would not display accurately, but the display on groups is just that, a display. Have you checked the hosts in the group do/do not have the location associated?



  • Can you tell me where I can find that info? I looked through the logs at /var/log/httpd/access_log (CentOS) but I couldn’t identify any errors related to this.

    Sorry I’m a Windows guy so I don’t know where to look for this info.



  • @kafluke can you look in the apache error logs for errors from the time when you tried? If you find any, please post them here in a code box.


Log in to reply
 

488
Online

6.2k
Users

13.6k
Topics

128.0k
Posts