Host Registration



  • Hi all,

    I have a mistake when i want register a new host. When i choose “Quick Registration and Inventory” I see “bzimage…ok” and “init.xz…”. In fog web I see on diagramm data send by my host. But i don’t see any host… Do you have a idea ?

    Thank you !



  • @skydraw35 said in Host Registration:

    I put the background and it work in Legacy/Bios for me !
    I have a last question, when i up/receive my image, can i put the uefi ?

    Not sure I follow you here. From the sounds of it registration works for you when BIOS/Legacy booted?

    Are you asking if you register it via BIOS can you then deploy/capture images in UEFI mode?

    I would think so, as long as you set the host machine to boot UEFI and the iPXE menu loads up. I dont think the registration of the machine is tied to BIOS/UEFI mode at all. Images and PXE booting are however, so you couldnt for example (at least not easily) capture a UEFI image and then deploy on a machine BIOS booted for example.

    With the change you made to DHCP, you should test and see if UEFI now works too for registration.



  • @zer0cool

    I tried to boot with Legacy/Bios and i have an error, i didn’t can start the FOG iPXE menu. After that i changed option 067 in my dhcp. I has replace ipxe.efi by undionly.kpxe and it work !!!

    I put the background and it work in Legacy/Bios for me !

    I have a last question, when i up/receive my image, can i put the uefi ?

    Thank You very much !! I think this ticket is solved :)

    Edit : I’m sorry @Quazz I did’nt see you message. I didn’t trie this solution I will test on the next computer !


  • Moderator

    What’s your FOG version?

    It’s always worth a shot to try a different boot file (eg snponly.efi instead of ipxe.efi)



  • @skydraw35 Worth a shot, not sure how narrow/broad the issue I had was.

    Permissions is possible, however I dont know where the server writes the registration info to.

    Does the same problem persist if you boot it in BIOS/Legacy mode? If it boots its unlikely to be permissions on the server.



  • @zer0cool

    I tried your solution @Zer0Cool but it doesn’t with me…

    I don’t think is the same problem, i can use the FOG iPXE menu perfectly and i don’t have any crash. Maybe rights on the fog server?



  • @skydraw35 Can it boot to the menu/registration if you boot in BIOS mode instead of UEFI?

    If so check this post https://forums.fogproject.org/topic/11972/ipxe-menu-colors-help/9

    I couldnt boot UEFI plugged into my dedicated GPU, only my iGPU. If you only have a single GPU, try removing the background like I mention and see if UEFI boots.



  • @george1421

    After have see bzImage + init.xz i return directly at the FOG iPXE menu and i always have “Host is Not registered”.

    The client computer is Hp ProBook 430 G5, I have desactived the secure boot because i can’t have FOG iPXE menu when it actived.

    And the BIOS firware is up to date.


  • Moderator

    @skydraw35 I don’t think another iPXE kernel is needed since you get into FOG iPXE menu and it tries to load FOS (bzImage + init.xz). So just to be clear, you see bzImage and init.xz then only a black screen no text at all?

    Since you are using ipxe.efi can we guess this is a uefi based computer? If so can we also guess it is lenovo? Even if not lenovo, please make sure the firmware is updated on the computer.

    Also what is the manufacturer and model of the target computer you are trying to register?



  • @george1421

    No, i don’t see anything…

    I use the ipxe.efi maybe i should change that ?



  • This post is deleted!

  • Moderator

    @skydraw35 said in Host Registration:

    I see “bzimage…ok” and “init.xz…”.

    You see both files sent to target computer. What happens after you see init.xz? You should see a bunch of text scroll on the screen as FOS starts and then runs its inventory steps. And finally FOS should reboot. Do you see any of that?


 

510
Online

41.6k
Users

12.1k
Topics

114.3k
Posts