WOL ? Computer boot/start alone



  • Hello,

    I have a curious problems with FOG ? (maybe ?) and WOL.

    FOG version: 1.5.4 on Debian 8.4
    3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64 GNU/Linux

    I explain:
    When a user stop the computer with windows menu Starts => Stop, the computer power off.
    That’s OK.
    But … avg 5 minutes after that a WOL signal wake up the computer … and it boot on fog menu pxe wait 5 sec with the fog menu and boot on the HDD.

    I’m sure the WOL signal it’s send by my FOG Server, because if i stop my FOG server the problem disapear.

    Nothing tasks into FOG WEBUI.

    I have used the wolbroadcast plugins. For the moment i have delete this plugins for see if the problems come from him.

    I precise, the problem appear on DELL Optiplex 9020.
    Several machines are concerned.
    Computers are conf for boot on HDD 1frst.
    BIOS are conf for WOL with PXE

    Have you any idea ?

    Thanks for answers/idea.



  • @steuve68 and in the end it was the online check from fog activating that computers, like i told you ;) I still have the ping check enabled i solved my problems around that with hibernating off und pattern match in nic drivers disabled.

    Regards X23


  • Moderator

    @steuve68 You won’t be able to see if hosts are online with it disabled but that should be it afaik.



  • @Tom-Elliott After uncheck PINGHOSTGLOBALENABLED, it’s OK.
    Computer don’t start/boot alone.
    WOL tasks always good ! :-)

    No secondary effect ?

    Thanks all :)



  • @tom-elliott OK thanks
    It’s that: PINGHOSTGLOBALENABLED ?

    No secondary effect if i uncheck this option ?


  • Senior Developer

    @steuve68 yes under fog settings Linux service.



  • @x23piracy I have test “powercfg -h off” with elevated privilege on 2 problematic computers
    No change: computers start always alone.

    For the moment the only solution what I found it’s up to date NIC Drivers … :-/

    @Tom-Elliott “Ping hosts just tests the status of a host.” => Can I disable this option into FOG ?

    Thanks all


  • Senior Developer

    @x23piracy why would I bash you. The only wake up code is in fog scheduler still.

    Ping hosts just tests the status of a host. The reason we use 445 @george1421 is so we can get a status. Ping itself just tests if the host is pingable, but that doesn’t necessarily mean anything. Using 445 we can get a real status like refused, no address, etc…

    So fog isn’t causing the problem being seen, but it is playing a part. That part is not by any means “fogs” fault, rather a configuration issue on the workstations.



  • @steuve68 here is a link for the 2 years old conversation i had with tom about it:
    https://pastebin.com/L1ixBrZd @tom-elliott don’t bash me for sharing this :)



  • @x23piracy No, i have just update NIC Device for test on this machine.
    But hibernation mode is off
    When i run: powercfg -a
    “La mise en veille prolongée n’a pas été activée”



  • @steuve68 have u tried to turn of hibernation by “powercfg -h off” in an evaluated cmd prompt?



  • So … I have update my Network Device Drivers
    I have enabled “Wake on Pattern Match” for test.

    For the moment the computer doesn’t start alone automatically.

    0_1528809578552_57152e2a-033c-4433-a727-e4322f4631a1-image.png

    I do not understand why suddenly the network drivers would be problematic.

    I suspect the update Microsoft KB4103718 (https://borncity.com/win/2018/05/27/windows-7-update-kb4103718-network-issues-fixed/) which is a priori known to pose problems with network card.

    That’s very strange …


  • Moderator

    @steuve68 said in WOL ? Computer boot/start alone:

    IP IPFOGSERVER.35593 > IPOFCOMPUTER.445

    This I can tell you is the fog server “pinging” the computer to see if its up. I can tell you that fog “pings” using this method instead of a traditional icmp ping. Why ?? I don’t know.

    This does sound like what x23 says a fog “ping” will wake up the host. After fog starts I don’t know what those packets are.

    I wonder of FOG will wake up the computer from a power up off state instead of a windows shutdown state?



  • @steuve68 can you please try to use “powercfg -h off” from one of the problematic computers? will they still turn on? You will need an evaluated cmd prompt to do this.



  • Hello,

    @x23piracy @george1421 Thanks for your answers.

    I have tried your solution @x23piracy .
    but … no way ! it doesn’t work ! Computer start always alone…
    I don’t understand why !

    0_1528804240614_7263a3ca-e728-4066-b7bd-093cb88f1351-image.png

    @george1421 No task into FOGWEBUI

    0_1528804359943_3bb9cd95-7636-4e6b-8aa8-2d648eff6b16-image.png

    When I stop computer I run:

    "tcpdump -i  eth0 '(udp and port 7) or (udp and port 9)' -vv -x | tee wol.log"
    

    on my FOG Server and … nothing but computer start always !

    If i run

    tcpdump -n dst host "IP OF COMPUTER START ALONE"
    

    i look:

    13:46:49.129590 IP IPFOGSERVER.35593 > IPOFCOMPUTER.445: Flags [S], seq 1711374309, win 29200, options [mss 1460,sackOK,TS val 2078989 ecr 0,nop,wscale 7], length 0
    13:46:50.126242 IP IPFOGSERVER.35593 > IPOFCOMPUTER.445: Flags [S], seq 1711374309, win 29200, options [mss 1460,sackOK,TS val 2079239 ecr 0,nop,wscale 7], length 0
    

    and my computer start and i look

    13:47:09.810532 IP IPFOGSERVER.46111 > IPOFCOMPUTER.2070: UDP, length 14
    13:47:09.812972 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 15
    13:47:09.813159 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.814626 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.815206 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.815913 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.816570 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.818901 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.819486 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.821192 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    13:47:09.821775 IP IPFOGSERVER.46892 > IPOFCOMPUTER.2071: UDP, length 1460
    

    Another idea ?



  • Hi,

    these are not wol pakets, i know that problem very well.
    There are nics outside supporting the feature “wake up on pattern match” that means a simply ping can wake a windows system.

    This happens because fog pings all known hosts to check if they are online.

    Check the nic driver in your task manager i will bet you will find an option like that.

    Bild Text

    If that option is enabled try to deactivate it.

    I suggest to change the way the server is detecting if the clients are online. @tom-elliott @Wayne-Workman @george1421 @joe-schmitt

    Regards X23


  • Moderator

    I have not heard of the fog server sending out random wake up commands before. Are there any active tasks in the fog task manager?

    I think you are testing right, just unplug the network cable that goes to the fog server and see if the issue stops. I have seen windows computers wake on their own before too.

    We may be able to create a specific capture string and have tcpdump program on the FOG server see if its sending out the magic wake packets to confirm if its FOG or something else waking up these computers. I must think about that task.


Log in to reply
 

430
Online

6.3k
Users

13.7k
Topics

128.9k
Posts