Installation fails



  • Hello,

    I’ve been working through various issues with the install script, mainly with the use of a proxy with curl and wget. However, I’m now at the backupdb step, and the wget seems to fail.

    I reviewed this forum post that gets stuck at the same spot :

    Backing up database…failed

    However, I have disabled the use of the proxy now, as the files needed are downloaded, and this step calls a local url.

    I can enter the following on another client web browser:
    http://192.168.X.X/fog/management/export.php?type=sqldump

    I receive a blank page (no errors). I see successful files created in the backup directory too:
    ls /home/user/fogDBbackups
    fog_sql_1.5.4_20180608_094600.sql
    fog_sql_1.5.4_20180608_083751.sql
    fog_sql_1.5.4_20180608_082642.sql
    fog_sql_1.5.4_20180608_074727.sql

    All four files present are zero bytes, however.


  • Moderator

    @aperiamb Try disabling the firewall as a test (and leave it disabled while we try to figure out what is the cause here so we don’t have to go back and forth)

    I personally suspect PHP-FPM to be the real culprit, a PHP error would produce a blank page on index.php (as opposed to an apache error page which will give an error code)

    What’s the output of

    tail -50  /var/log/php-fpm/www-error.log
    

    and

    tail -50  /var/log/php-fpm/error.log
    


  • @quazz I followed the guides for firewall and SELinux in this guide :
    https://wiki.fogproject.org/wiki/index.php?title=CentOS_7

    So no to firewall (set rules) and yes to SELinux.

    I can reach the apache test page, but when I add /fog, it redirects me to the /fog/management/index.php page, which is blank. I suspect this has something to do with my installation not being complete.


  • Moderator

    @aperiamb Did you disable SELinux and the firewall?



  • @quazz Thanks for clearing that up for me.

    I have zero clients, as I haven’t been able to finish the installation script.



  • @sebastian-roth
    My apache log :

    
    
    [Sun Jun 24 03:24:02.916850 2018] [auth_digest:notice] [pid 60779] AH01757: generating secret for digest authentication ...
    
    [Sun Jun 24 03:24:02.921576 2018] [lbmethod_heartbeat:notice] [pid 60779] AH02282: No slotmem from mod_heartmonitor
    
    [Sun Jun 24 03:24:03.028341 2018] [mpm_prefork:notice] [pid 60779] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16 configured -- resuming normal operations
    
    [Sun Jun 24 03:24:03.028403 2018] [core:notice] [pid 60779] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    
    [Wed Jun 27 07:50:42.863944 2018] [autoindex:error] [pid 4619] [client 192.168.60.55:50892] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive
    
    [Thu Jun 28 03:40:02.555202 2018] [mpm_prefork:notice] [pid 60779] AH00171: Graceful restart requested, doing restart
    
    [Thu Jun 28 03:40:02.900762 2018] [auth_digest:notice] [pid 60779] AH01757: generating secret for digest authentication ...
    
    [Thu Jun 28 03:40:02.904632 2018] [lbmethod_heartbeat:notice] [pid 60779] AH02282: No slotmem from mod_heartmonitor
    
    [Thu Jun 28 03:40:03.021614 2018] [mpm_prefork:notice] [pid 60779] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16 configured -- resuming normal operations
    
    [Thu Jun 28 03:40:03.021780 2018] [core:notice] [pid 60779] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
    

  • Developer

    @aperiamb Please check your apache error logs. See my signature…


  • Moderator

    @aperiamb Mariadb is a Mysql fork, which should be fully compatible with its standards, but they include certain fixes, changes, optimizations that are really nice.

    Sometimes the logfiles and references will still say mysql, sometimes mariadb, the distinction isn’t terribly important in most cases.

    Logfile seems clean as well, this should mean that your database is in good shape which is good news.

    So the question remains why you’re getting a 500 error then.

    Do you have a lot of clients and such?

    I’m going to presume that the problem is actually down to PHP.



  • @quazz This brings up something that confused me during installation. The docs mention both mysql and mariadb. Which one does fog use?

    When I looked for the logs in /var/log/ there was only a mariadb folder, which had the mariadb.log inside.0_1530104131221_fogmariadb.txt


  • Moderator

    @aperiamb Looks like it should be to me.

    Perhaps the problem is with the Mysql server instead.

    There should be an error log of it in /var/log somewhere (possibly in a mysql folder)




  • Moderator

    @aperiamb Thinking about it a little bit, a 500 error is frequently caused by incorrect permissions.

    What’s the output of

    ls -lah /var/www/html
    

    and

    ls -lah /var/www/html/fog
    


  • @Quazz

    It looks like the web server is up, but returning a 500 on requests.



  • @quazz

    Here’s some of the output from the bottom of that file:

    Getting CA Private Key
    
    ln: failed to create symbolic link ‘/var/www/html/fog/fog’: File exists
    
    ● httpd.service - The Apache HTTP Server
    
       Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    
       Active: active (running) since Fri 2018-06-08 09:45:58 CDT; 2s ago
    
         Docs: man:httpd(8)
    
               man:apachectl(8)
    
    Main PID: 60779 (httpd)
    
       Status: "Processing requests..."
    
       CGroup: /system.slice/httpd.service
    
               ├─60779 /usr/sbin/httpd -DFOREGROUND
    
               ├─60786 /usr/sbin/httpd -DFOREGROUND
    
               ├─60787 /usr/sbin/httpd -DFOREGROUND
    
               ├─60788 /usr/sbin/httpd -DFOREGROUND
    
               ├─60789 /usr/sbin/httpd -DFOREGROUND
    
               └─60791 /usr/sbin/httpd -DFOREGROUND
    
     
    
    Jun 08 09:45:57 FOG01.local systemd[1]: Starting The Apache HTTP Server...
    
    Jun 08 09:45:58 FOG01.local systemd[1]: Started The Apache HTTP Server.
    
     
    
    ● php-fpm.service - The PHP FastCGI Process Manager
    
       Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled; vendor preset: disabled)
    
       Active: active (running) since Fri 2018-06-08 09:45:57 CDT; 2s ago
    
    Main PID: 60780 (php-fpm)
    
       Status: "Ready to handle connections"
    
       CGroup: /system.slice/php-fpm.service
    
               ├─60780 php-fpm: master process (/etc/php-fpm.conf
    
               ├─60781 php-fpm: pool www             
    
               ├─60782 php-fpm: pool www              
    
               ├─60783 php-fpm: pool www             
    
               ├─60784 php-fpm: pool www             
    
               └─60785 php-fpm: pool www             
    
     
    
    Jun 08 09:45:57 FOG01.local systemd[1]: Starting The PHP FastCGI Process Manager...
    
    Jun 08 09:45:57 FOG01.local systemd[1]: Started The PHP FastCGI Process Manager.
    
    --2018-06-08 09:46:00--  http://192.168.60.19//fog//maintenance/backup_db.php
    
    Connecting to 192.168.60.19:80... connected.
    
    HTTP request sent, awaiting response... 500 Internal Server Error
    
    2018-06-08 09:46:01 ERROR 500: Internal Server Error.```

  • Moderator

    @aperiamb What’s the output of tail -25 error_logs/fog_error_1.5.4.log

    (assuming you’re in the bin folder where installfog.sh is)



  • Sorry, forgot to include that. This is Cent0S 7-1804. mysql was not installed prior.


  • Moderator

    Server OS and version?

    Was mysql already installed prior to FOG installation? (is it configured with a root password?)


Log in to reply
 

492
Online

6.2k
Users

13.6k
Topics

128.0k
Posts