Centos7/Fog 1.5.3 - image capture fails with incorrect date.timezone info

  • Hi All,

    We are retiring our old Fog v1.2 server running on Centos 6 so I spun up a new Centos 7.5.1804 server and installed Fog 1.5.3 with default settings. The Fog setup proceeds normally and completes. Looks good so I tried a capture test using a HP Elitebook 840 laptop running Win10

    -define an image for Windows 10
    -define a host and assign the Win10 image
    -create a task for defined host to capture an image from a Win10 client
    -network boot the Win10 client and Fog capture initializes
    -partimage screen starts and progresses through
    -reports 43 GB used out of a 500 GB HDD - seems accurate
    -partimage exits after showing process is 100% complete
    -fog is writing data to the /images directory all through the process, plenty of free space available

    Then the black console screen comes up on the Win10 client to finalize the upload and it fails with this …


    (sorry cropped the image when taking the screenshot).

    The Centos system timezone is set correctly and the time is within 0.1 ms (ntp).

    Fog Configuration -> Fog Settings -> General Settings -> TZ INFO = 'America/New_York[EDT -04:00]

    Looks right.

    So I’m trying to figure out why the capture fails after an hour a progress in the last seconds of the image capture.

    Any advise would be greatly appreciated.

    Thanks in advance,

  • An update, solved.

    There were two issues.

    The timezone issue was resolved by setting the Centos system to to UTC and Fog’s ‘TZ INFO’ setting to UTC. Don’t know why setting to ‘UTC’ worked and not with the same settings using ‘EDT’ <shrug>. Once we catch up on our imaging I’ll try to revert back to our timezone and see if this is merely an annoying warning or if it still causes a fatal error.

    The second issue was the user ‘fog’ passwords were not consistent, system vs. Fog account. So when Fog completed the imaging and during the ‘Updating Database’ routine the ftp login failed and threw ‘Error returned: Type 2’.


    We are now able to image Window 10 clients for the first time! Thanks everyone for your help!


  • Senior Developer

    Restart the services (or the server if that’s easier) to see your change take effect. Remember, the services run on boot, so whatever their settings were when it started still is in effect until restarted.

  • I’m running another capture of a Window 7 client after restarting fog but it will be an hour before it gets to 99% and where it would normally fail.

    While waiting I was looking for error messages related to why it fails in /var/log/fog and discovered FOG is still using a different timezone than the OS system time and what is set within FOG (TZ INFO)

    [root@fog fog]# date
    Thu Jun  7 11:27:59 EDT 2018
    [root@fog fog]# ls -la
    total 172
    drwxr-xr-x. 2 root root   218 Jun  7 10:17 .
    drwxr-xr-x. 5 root root    67 Jun  5 12:57 ..
    -rw-r--r--. 1 root root  2587 Jun  7 11:17 fogimagesize.log
    -rw-r--r--. 1 root root 12822 Jun  7 11:27 fogreplicator.log
    -rw-r--r--. 1 root root  4320 Jun  7 11:27 fogscheduler.log
    -rw-r--r--. 1 root root  2400 Jun  7 11:17 fogsnapinhash.log
    -rw-r--r--. 1 root root  4552 Jun  7 11:27 fogsnapinrep.log
    -rw-r--r--. 1 root root 88341 Jun  7 11:27 groupmanager.log
    -rw-r--r--. 1 root root 18526 Jun  7 11:28 multicast.log
    -rw-r--r--. 1 root root  2565 Jun  7 11:27 pinghost.log
    -rw-r--r--. 1 root root 17783 Jun  7 10:17 servicemaster.log
    [root@fog fog]# tail -4 fogscheduler.log
    [06-07-18 3:24:46 pm]  * No tasks found!
    [06-07-18 3:25:46 pm]  * No tasks found!
    [06-07-18 3:26:46 pm]  * No tasks found!
    [06-07-18 3:27:46 pm]  * No tasks found!
    [root@fog fog]# 

    So fog thinks its 3:27pm (basically UTC/GMT) when the system time is 11:27:59 EDT … and Fog Configuration -> Fog Settings -> General Settings -> TZ INFO is set to EDT 'America/New_York[EDT -04:00]

  • Moderator

    You shouldn’t have to set date.timezone in your php.ini file (just checked, it’s commented out and blank on my end). I think it is sent dynamically based on your selection in the GUI.

    GUI looks normal too. (same as on my end).

    There might be a strange problem with a specific timezone, so maybe pick one at random and see if that one does work?

  • No error in the web GUI, ultimate the progress bar under Tasks just hangs at 91% complete after the error on the client is shown on the client.

    In my Fog settings, the TZ INFO selections all have the offset next to the name, even America/Detroit

    Regarding /etc/php.ini, the ‘date.timezone’ setting was commented out. Again, this was a default Centos/Fog installation so that is a an out of the box ‘php.ini’.

    I will experiment with the America/New_York[EDT -04:00] vs America/New_York setting if it lets me and let you know the result.


  • Moderator

    Well this is a super interesting error. You don’t get any kind of error like this using the web gui?

    There are two places where the timezone settings could be.

    /etc/php.ini search that file for date.timezone =

    … wait, I just noticed you have America/New_York[EDT -04:00] and not America/New_York I wonder if that extra text is what its not happy with.

    In my case I have America/Detroit set in both FOG Web UI and in php.ini. If you update php.ini, just reboot the fog server (or restart php-fpm and apache)

Log in to reply