iPXE Fedora 28 Workstation Boots Live, Not Installer



  • FOG 1.5.2
    CentOS 7.5

    Trying this on a physical host, a Dell 3620 in UEFI and in BIOS modes. When I select my option from the iPXE menu to install Fedora it boots up to basically the Live CD instead, giving me a desktop, letting me pick some of the post install options (like data collection and creating a user). I do not however have any options to install to disk. A reboot effectively destroys the environment as it was running in memory.

    here is the menu entry:

    kernel http://${fog-ip}/fog/os/fedora/ws/images/pxeboot/vmlinuz
    initrd http://${fog-ip}/fog/os/fedora/ws/images/pxeboot/initrd.img
    imgargs vmlinuz initrd=initrd.img root=live:http://${fog-ip}/fog/os/fedora/ws/LiveOS/squashfs.img ip=dhcp repo=http://${fog-ip}/fog/os/fedora/ws splash quiet
    boot || goto MENU
    

    I would suspect it has to do with the root=live portion of my entry, but its almost identical for CentOS and that starts to the installer as expected.

    I have been scouring for documentation or any reference online to a working iPXE entry for Fedora but they all basically look like what I have.

    Any help would be greatly appreciated, Thanks



  • @Zer0Cool I know im late to the party but…

    The way to run the installer from the live only mode with fedora is with the command

    sudo liveinst
    

    then bam the installer will start and all will be well with the world

    I found the answer here [https://docs.fedoraproject.org/en-US/Fedora/16/html/Fedora_Live_Images/sect-Fedora_Live_images-Installing_Fedora_from_the_Live_Image.html](link url)



  • @george1421 All good, got it!

    This is what worked for me:

    kernel http://${fog-ip}/fog/os/fedora/ws28/images/pxeboot/vmlinuz
    initrd http://${fog-ip}/fog/os/fedora/ws28/images/pxeboot/initrd.img
    imgargs vmlinuz initrd=initrd.img repo=http://${fog-ip}/fog/os/fedora/ws28
    boot || goto MENU
    

    my repo=http://${fog-ip}/fog/os/fedora/ws28 line is the path to where I have rsyncd the mirror path/releases/28/Workstation/x86_64/os/ to.

    Thanks again.



  • @george1421 Yea That was my point the repo has a different structure than the DVD. I rsyncd the repo and am trying the install now but it looks like it may have hung during booting Fedora…ill see if I can work it out.

    EDIT: yea starting getting dracut initqueue errors just repeating.


  • Moderator

    @zer0cool Without downloading the fedora 28 iso I can’t say for sure. But did you look at https://mirrors.rit.edu/fedora/fedora/linux/releases/28/Server/x86_64/os/ with a browser? Do you see a similar structure on the fedora dvd?

    Cloning that repo path may be the easiest solution.



  • @george1421 So this is a bit weird (to me at least), but Fedora only seems to offer a net installer iso or a Live iso, the Live iso doesnt have the os directory.

    I have been digging and I could probably just rsync the repo (the portion I need) like I do for CentOS and use it as the install media but was wondering if I am missing something more simplistic?

    The net installer isnt an option and I couldnt find a “self contained” iso like the CentOS DVD.

    Any advise?

    PS: no one is perfect…but you are certainly awesome :)


  • Moderator

    @zer0cool said in iPXE Fedora 28 Workstation Boots Live, Not Installer:

    you may consider updating it if I may be so bold. Did they change from 27 to 28 how you PXE boot

    No body said I’m perfect either. I saw the desktop when I was setting it up so I said, done!! Some installers are run from the live image, like linux mint.



  • @george1421 As always, you are a great help! I will give it a shot shortly and report back.

    My menu entry, by the way, is based off your guide ;) you may consider updating it if I may be so bold. Did they change from 27 to 28 how you PXE boot?

    Thanks


  • Moderator

    Have you reviewed this document: https://docs.fedoraproject.org/f28/install-guide/advanced/Network_based_Installations.html
    Specifically the section labeled “Configuring client bootloaders”

    That shows the pxelinux configuration of

    label linux
    menu label ^Install Fedora 28 64-bit
    menu default
    kernel f28/vmlinuz
    append initrd=f28/initrd.img inst.stage2=http://download.fedoraproject.org/pub/fedora/linux/releases/28/Server/x86_64/os/ ip=dhcp
    
    label server
    menu label ^Install Fedora 28 ( Minimal Image )
    menu default
    kernel f28/vmlinuz
    append initrd=f28/initrd.img inst.stage2=http://download.fedoraproject.org/pub/fedora/linux/releases/28/Server/x86_64/os/ ip=dhcp ks=https://example.com/fedora/kickstarts/minimal.ks
    
    

    You might rewrite the line into ipxe format like this

    kernel http://${fog-ip}/fog/os/fedora/ws/images/pxeboot/vmlinuz
    initrd http://${fog-ip}/fog/os/fedora/ws/images/pxeboot/initrd.img
    imgargs vmlinuz initrd=initrd.img nst.stage2=http://download.fedoraproject.org/pub/fedora/linux/releases/28/Server/x86_64/os/ ip=dhcp
    boot || goto MENU
    

    Your imgargs line does tell the installer to boot into the live environment. Now in what I just wrote you need to chagne the path from download.fedora… to the location of your x64 os install. You could even create a custom kickstart script to do a special install how the server line lists.


Log in to reply
 

410
Online

6.3k
Users

13.7k
Topics

129.3k
Posts