Problem of closing the activity of the snapin in task management



  • Hi I have a problem with the FOG Snapin works.
    The version of FOG installed is 1.5.2.
    I created a snap-in with a powershell script that runs correctly on the host, but in task management,
    its activity is permanently running, relaunching the same snap-in on the host, always running it correctly
    until I manually delete the task from the task management. So I went to see the log file,
    the result of the snap-in is shown below:


    --------------------------------- ---------------- SnapinClient -----------------


    25/05/2018 13:08 Client-Info Client Version: 0.11.16
    25/05/2018 13:08 Client-Info Client OS: Windows
    25/05/2018 13:08 Client-Info Server Version: 1.5.2
    25/05/2018 13:08 Middleware :: Response Success
    25/05/2018 13:08 SnapinClient Running snapin IPStatico
    25/05/2018 13:08 Middleware :: Communication Download: http://10.16.16.3/fog/service/snapins.file.php?mac=9C:5C:8E:20:82:E6&taskid=117
    25/05/2018 13:08 SnapinClient C: \ Program Files (x86) \ FOG \ tmp \ SnapIPStaticoPs1.zip
    25/05/2018 13:08 SnapinClient Processing SnapinPack SnapIPStaticoPs1.zip
    25/05/2018 13:08 SnapinClient Extracting SnapinPack
    25/05/2018 13:08 Bus Emmiting message on channel: Notification
    25/05/2018 13:08 SnapinClient Starting snapin
    25/05/2018 13:08 SnapinClient Snapin finished
    25/05/2018 13:08 SnapinClient Return Code: 0
    25/05/2018 13:08 Bus Emmiting message on channel: Notification
    25/05/2018 13:08 Middleware :: Communication URL: http://10.16.16.3/fog/service/snapins.checkin.php?taskid=117&exitcode=0&mac=9C:5C:8E:20:82:E6&newService&json
    25/05/2018 13:08 Middleware :: Communication ERROR: Could not contact FOG server
    05/25/2018 13:08 Middleware :: Communication ERROR: Unable to connect to remote server.


    I noticed that it is a communication error but if I take the url:

    http://10.16.16.3/fog/service/snapins.checkin.php?taskid=117&exitcode=0&mac=9C:5C:8E:20:82:E6&newService&json

    and I report it in any browser he permanently closes me the activity of the snapin in question.
    At this point I ask you if anyone can help me, because I do not know if it’s a configuration problem or a software bug.
    In addition I tried to uninstall and reinstall the FOG Client, to reset the encryption data without solving the problem.



  • @sebastian-roth
    Thanks to the suggestion, the tcpdump software helped me to understand that the host did not send any data packet to the FOG server during the closing phase of the snap-in. All this was due to the fact that my script assigns a static IP to the Host when certain parameters occur, so, in the IP assignment phase, the Host was offline and the snap-in was unable to communicate with the FOG server. So I solved the problem by inserting a 10-second pause in the script with the powershell start-sleep command, allowing the Host to return online before closing the snap-in.
    I wanted to thank you for your availability and tell you that you are doing a great job with FOG.



  • Thanks for your help, I will do what you have requested and I will send you the file


  • Developer

    @federicobarbella Kinda strange that the download succeeds but the exit checkin fails. I guess we need to see a network packet dump to figure out what could be wrong here. So please install tcpdump on your FOG server and run sudo tcpdump -w snapin_issue.pcap host a.b.c.d (put in the client’s IP address instead of a.b.c.d). Now schedule the snapin for this client again - best to do this from a different machine to prevent from having that un-needed web traffic in the packet capture as well! Check the logs on the client to see when it finished and stop tcpdump (Ctrl + c) after that. Upload the pcap file to a shared drive and post a link here (or send me a private message if you don’t want to share this in public).


Log in to reply
 

530
Online

6.2k
Users

13.6k
Topics

128.3k
Posts