failed to get IP & unable to register host



  • Hey guys,

    I finally decided to give FOG a try… After I finally got it all to actually show something after booting over iPXE (I had to adjust the router’s file names) I just ran into the next problem when trying to do a “Full Host Registration and Inventory”…

    Well actually there are multiple problems I believe:

    1. Unkown controller version
    2. failed to get IP via DHCP
    3. unable to register host: (/bin/fog.man.reg)

    I really have no clue… What is going on???

    Any help now is greatly appreciated!

    alt text

    I run the latest version on Ubuntu 16.04, my Router is a pfsense box and the device in question here is a Thinkpad Yoga 460…



  • @george1421 That is good to know, I will then probably try to update the kernel every once in a while…

    I currently have Win 1709 and use Proxmox, let’s hope that there will be no problems ;)


  • Moderator

    @kreios Under the fog settings there is a kernel update option where you can download new kernels. But if you just installed FOG you will have the latest stuff since the installers will download latest on each install.

    If you are using hyper-v and 1803 version of win10, there has been reports of people not able to pxe boot into the FOG menu. This appears to be an issue with iPXE and hyper-v under 1803 only.



  • @george1421 ah ok, that is good to know!

    Well let’s hope, that they do so… the new kernel will probably come with a fog update or how will I get it?

    Let’s try booting some VMs with my Laptop image…

    Thank you very much for your help!


  • Moderator

    @Kreios You can ignore the 2 messages above where it was complaining about eth0. They are more of a warning message than something’s broke.

    as far the registration, at the end of registration it will ask you do you want to image right away. That question assumes you already have captured an image. This will be a short cut for you when you have your images already captured and are deploying more computers. You can just answer No to that question.

    Its great that you found an adapter that works. Once the linux kernel developers have a driver created for your onelink then your bigger dock will be supported by fog.



  • I then followed this guide: https://wiki.fogproject.org/wiki/index.php?title=Booting_into_FOG_and_Capturing_your_first_Image

    It stated to create the image after registration. But during registration it already asks for an image ;)



  • @george1421

    Yeah lost my mind when thinking about wifi…

    Luckily I had a USB to Ethernet Adapter in another PC… But it won’t recognize it as an ethernet device during boot…

    So I tried my other One-Link dock (the small one that comes with the laptop, with only LAN and VGA) and it worked!

    The first two errors still persist though…


  • Moderator

    @kreios The last I know the onelink adapters have an issue with linux in general. If you have a supported usb ethernet adapter that seems to work better than the onelink. Wifi is not an option to image over. FOS does not contain wifi drivers and there is no way to add in the access point information.



  • @george1421

    oh shoot…! Why do I have so much bad luck… :(

    I have my Yoga connected to a OneLink+ Dock (which has a LAN port…). I thought that it would be better to try it with a cable… But now that you say it, I will probably try over wifi as well!

    I could also try another Ethernet Adapter (which also runs over Onelink+).

    EDIT why does my replay show up before your post? that is really strange…


  • Moderator

    Firstly, thank you for trying FOG.

    I do have to say you started with the most troubling hardware we’ve seen. Sometime the yogas are a real pain to get working.

    For now lets ignore that MMC0 error. That error is around the SD/MMC card reader that is not used with FOG, and is an issue between linux and your hardware.

    The most troubling issue I see is that no network link is detected on eth0. Its good that FOS sees the network adapter since it has identified eth0. What ethernet adapter are you using with the yoga. It is obviously working since you got FOS transferred (bzImage + init.xz) using the iPXE menu.


Log in to reply
 

501
Online

6.3k
Users

13.7k
Topics

129.0k
Posts