kernel panic HP DC5800 worked in fog 0.32



  • Computer is HP DC5800.

    We were able to image this machine with fog version 0.32

    I recently installed Ubuntu 18.04 and latest fog 1.5.x

    We get the errors that are in the screenshot. I have tried ever kernel.
    How do you fix this?
    0_1526910158656_Optimized-fog-error1.jpeg 0_1526910403083_fog-error2.jpeg


  • Moderator

    @cs_pccs Please start a new thread since your conditions are likely different than the OP, unless you just upgraded from 0.32 version of FOG.

    Please include any images you feel are relevant in your post. HINT: A clear picture of the error provides us with an idea of the context of the error as well as the exact error message.

    You need to use the kernel and inits shipped with FOG 1.5.4 (almost) or you will have an unsuccessful deployment. FOG kernel 4.17.0 is shipped with FOG 1.5.4. There is something wrong with that kernel version, it takes minutes to create partition tables on target computers. This is not a FOG issue per se, but a linux kernel issue. But to the point roll your FOG kernel back to 4.15.2 via the FOG Settings -> FOG Kernel menu. Also note that the inits are tied to the kernel version, so you need to put the FOG 1.5.4 inits back in place or you will get an error message. Once you provide the info in your own thread, we can start to dive into your issue.



  • Recently built from scratch new Fog 1.5.4 servers on Ubuntu 16.04 LTS using new hardware. Have the identical issue on identical hosts. I thought I made progress by copying both the kernel and init files from 1.4.3 (named them OldPC and OldPC.xz) and have the host using these. I got past the Kernel Panic but the client “Attempting to check in… Failed”.
    I’m able to still image off the old 1.4.3 server so not a big issue for me but I still have a few hundred DC5800 machines I’ll need to support for awhile. I did copy and try OldPC32 and OldPC32.xz as well along with the other suggestions in this thread.

    Newer PCs work great. Thanks for any suggestions.


  • Moderator

    @mike-fahey To use your words, they are all kitchen sink now.

    You need to ensure that the kernel and the inits are of the same generation and correctly aligned. The error messages you have so far are related to kernel/init mismatch.



  • @tom-elliott I did change the boot file to undionly.kpxe.
    I’m pretty sure we needed to use a kitchen sink kernel for this machine in the past.
    WHat happened to those kernels? can you provide any information about the tomelliott kernels?
    Is there any documentation on what these kernels contain? are they all kitchen sink?

    I will try updating the init_32.xz as suggested.


  • Moderator

    Of course I agree with Tom.

    Lets backup and confirm what do you have configured for dhcp option 67 {boot-file}?

    Also in your first picture the kernel is too old is that you have your inits (init.zx) are not in sync with you kernel (bzImage) files. One thing that is to be aware of, is that FOG 0.32 used a 32 bit kernel and inits. The kernel name is bzImage. With the newer releases of FOG bzImage is a 64 bit kernel which needs 64 bit inits. I can see the error created in picture 2 to be caused by having mismatched kernel and inits (64 vs 32 bit).

    so lets see if we can get your kernels and inits back in sync and up to date. You will need to access the linux command prompt on your fog server.

    # become root
    sudo su -
    
    # Change to the kernel and inits directory
    cd /var/www/html/fog/service/ipxe
    
    #download the proper files. 
    wget https://fogproject.org/inits/init.xz
    wget https://fogproject.org/inits/init_32.xz
    wget https://fogproject.org/kernels/bzImage
    wget https://fogproject.org/kernels/bzImage32
    

    That will ensure you have your inits and kernels back in sync.
    Now pxe boot a host, unregister it if its registered.
    Then pxe boot a host and register it using the full register menu.

    Does it boot into the registration menu?


  • Senior Developer

    @mike-fahey often this is seen for one of two primary reasons. First reason is usually people switching from 0.32 and not switching the boot file from pxelinux.0 to undionly.kpxe. I don’t think this is the issue you’re experiencing as it seems to be looking at ipxe before handing off to the kernel and init. The second method I see this happening with is the kernels have been setup to work with 32 bit AND 64 bit systems natively. This means there’s an initfs and kernel for both of these modes. They are not interchangeable. Meaning you can’t boot the 64 bit init with a 32 bit kernel and vice versa.

    There is the possibility the system being booted is missing some set of drivers though that will make it much harder to figure you which is which. Assuming this machine is already registered, you could try booting the 32 bit information natively to see if that helps. Go to the host in question and in the kernel and init fields place bzImage32 and init_32.xz respectively.



  • @Tom-Elliott Do you have any suggestions? It would be greatly appreciated.



  • @george1421 as recently state above I installed Ubuntu 18.04 and fog 1.5.2.
    The errors above is what we get with this specific machine.

    My point was this hardware set imaged without a problem using fog 0.32


  • Moderator

    Just to be clear you are running fog 1.5.2 at the moment? Because if you have FOG 0.32 you will be out of luck in so many ways.



  • To Note: we try every single kernel available in fog 1.5


Log in to reply
 

491
Online

6.2k
Users

13.6k
Topics

128.0k
Posts