Multicast working great, but...



  • Hello - I tried to image 20 PC’s this morning and most of them worked just great. I have a few PC’s that will not PXE boot when WOL tells them to wake up - they boot right to the hard drive, and there is no place in the bios where I can change it. These are older Lenovo Thinkcentre M55e’s. I am using the windows client - I was under the impression that if you enable task reboot on the server and the client, if a PC is up and running windows it will reboot itself when the client finds a task. Is this how it works? Because that’s not happening. If it is the way it’s supposed to work, what am I doing wrong?

    Thanks -

    LibraryMark



  • [quote=“Icak_newton, post: 620, member: 249”]You can burn multiple ipxe cd’s and let the pc’s boot from them :)[/quote]
    Yeah… I could. But i’m not ;)

    As it turns out, I am able to use the FOG service to reboot when there is a pending task. It all works pretty well now.



  • You can burn multiple ipxe cd’s and let the pc’s boot from them :)



  • So I think I got the reboot on pending task running - I had to edit the file c:\program files\FOG\etc\config.ini and set forcerestart=1. Our computers are all set to auto login so there will never be a time when they aren’t logged in. Once I got that set the PC’s rebooted once I queued up a task. Cool stuff!

    I am still going to look for the proper BIOS setting, but I am not sure it exists on these machines. They came with windows XP COA’s so they’ve got some age to them. BIOS updates didn’t seem to fix it either.



  • The FOG service will reboot if an image task is assigned to that host, assuming the FOG service Task Reboot is set on the console in both the global FOG services page and on the individual hosts services page… and I think they also need to have Auto Log Out enabled as well. It’s been a while since I used the FOG service, but I recall that being a stumbling point when first implementing it.

    As for the WOL PXE booting; most BIOS have a separate setting for the boot order of WOL, generally listed under WOL or Power Management.



  • I guess I need to ask if the FOG service client is supposed to work the way I think it does - to poll the server and if there is a task, reboot the computer. If it works this way, that would solve my problem, but I am not sure if it’s supposed to do that.



  • Sure - On these Lenovo’s it’s F1. I set it to boot to PXE. When I restart the PC, it does PXE boot. It’s when it’s woken up from Wake On Lan that it bypasses the PXE.



  • [quote=“LibraryMark, post: 523, member: 115”]Hello - I tried to image 20 PC’s this morning and most of them worked just great. I have a few PC’s that will not PXE boot when WOL tells them to wake up - they boot right to the hard drive, and there is no place in the bios where I can change it. These are older Lenovo Thinkcentre M55e’s. I am using the windows client - I was under the impression that if you enable task reboot on the server and the client, if a PC is up and running windows it will reboot itself when the client finds a task. Is this how it works? Because that’s not happening. If it is the way it’s supposed to work, what am I doing wrong?

    Thanks -

    LibraryMark[/quote]

    Can you access the boot device menu on the lenovo with F9 or whatever key it is?


Log in to reply
 

448
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.