[SOLVED] Can't upload images



  • This is the first time I’ve ever tried to use FOG. I wiped an old server off and loaded Fedora Core 17 on it.
    I’m at the point that the clients boot off PXE and I get the FOG menu, and I can get the clients to register with the FOG server, but I can’t upload images from the client to the server.
    When I click the Upload image button, it looks like the next page only half loads - it says Task Management across the top, and has all the standard icons above where it says Task Management, but there’s nothing else on the page.
    Also, there is not anything created in the pxelinux.cfg directory. Rebooting the client computer it just gives the regular FOG menu again.
    Anyone have any ideas?

    Thanks



  • Actually it was pretty straightforward to get working on FC17 -

    1. Follow instructions found in other posts for Fedora Core 16 (Remove php-gettext from the install file, fix the NFS-server start so it won’t break the install process)
    2. Replace &$tmp with $tmp
    3. Start the NFS-server / enable the nfs-server

    I just successfully re-imaged a computer :D


  • Moderator

    Plugged one hole in the boat just to find another. You can try Fedora 16, or Ubuntu 10.04 LTS I guess. I know 10.04 LTS works well for me and supports my Dell PERC for my array.



  • Never mind, the nfs-server didn’t get turned ‘on’ by chkconfig properly. I started it and got an error that I was trying to image to many partitions at once, so I think we’re good now! Thanks for your help.



  • That cleared the first error up - now I’m getting another one:

    Preparing to send image file to server
    Mounting File System… mount: RPC: Remote system error Connection refused
    mount: mounting 192.168.10.113:/images/dev/ on /images failed: Bad file descriptor
    Done
    Fatal Error: Failed to mount NFS Volume.



  • I’ll give it a shot, thanks


  • Moderator

    I looked through the 0.32 code base at the file you are having problems with. It seems it’s calls to two functions: createSingleRunScheduledPackage and createCronScheduledPackage. In both calls, the 8th argument is being passed by reference in the function call. I tracked the two functions back to the functions.include.php and both functions show the 8th argument is defined as pass by reference.

    So you should be able to search the /var/www/fog/management/includes/tasks.confirm.include.php for all instances of “&$tmp” and replace them with just “$tmp” since the functions already know that argument is by reference and doesn’t need the function call trying to help it.

    I used grep to find all non function definition uses of &$ and there are none outside of this one file. so 22 replaces of &$tmp with $tmp should fix this issue.



  • Yes, I gave up on this and I’m downloaded FC16 now, it was definitely a lot more trouble than it was worth to try and stick with FC17.


  • Moderator

    nevermind, you’ll have to change the code everywhere a function call it made that uses a pass by reference. Doesn’t sound like there are too many or it’d be failing all over the place.



  • SO a bit of searching in Google shows that that error is due to the functiong being removed in PHP 5.4, the easy solution of course is to downgrade to Fedora Core 16 which comes with PHP 5.3 and still has the missing function. I’m trying the hard way (compile and install PHP 5.3 on Fedora Core 17). Wish me luck.



  • I looked through the HTTPD error log, it looks like PHP is the thing that’s failing on me -
    There are a lot of Notice messages, this one is the only one that says Fatal Error -
    [Thu Sep 13 15:24:13 2012] [error] [client 192.168.10.47] PHP Fatal error: Call-time pass-by-reference has been removed in /var/www/html/fog/management/includes/tasks.confirm.include.php on line 754, referer: [url]http://images/fog/management/index.php?node=host&sub=edit&tab=tasks&id=1[/url]
    I could go to FC16, but it’s such a pain to reload the machine I want to avoid it if possible

    PHP Version is 5.4.6


  • Moderator

    I don’t think FOG 0.32 works well with Fedora 17. I think you can use Fedora 16, or Ubuntu 10.04 LTS to get the best results.

    If you must use Fedoria 17, check your TFTP configuration to make sure it’s working.


Log in to reply
 

416
Online

38951
Users

10701
Topics

101531
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.