Failed to get an IP via DHCP (only on a certain switch)



  • I’m receiving this error on any computer plugged into a certain Cisco switch. They’re able to reach the FOG boot menu but won’t go any farther. I receive the error when selecting full host registration, deploy image, debug, etc.

    Like I said, it only happens on a certain switch. Any computer plugged into the unmanaged switch works just fine. They can connect to FOG, register, deploy, and capture images. I’ve tried manually adding the computers to the host list but it doesn’t solve anything.

    Also I wanted to note that I’m using Dnsmasq. Not sure if that affects anything.

    Any ideas? Pretty sure it’s something to do with the switch configuration but I’m not sure what specifically. I’m not very experienced.

    Thanks!



  • @george1421 Your suggestion worked! Thank you very much.


  • Moderator

    @crtech99 Ok I guess we need a bit more info then. What you described seems similar to not having RSTP enabled. But that issue usually appears just after the iPXE boot kernel is transferred to the target computer.

    What error do you see after you reach the FOG iPXE menu? A clear screen shot of error would give an idea to the context of the error. (I’m still thinking spanning tree, especially if you can place an unmanaged switch between the building switch and the pxe booting computer and it works).

    Edit: OK I’m blind I missed your follow up post. Let me know before we proceed.



  • @george1421 Actually nevermind, they’re not. Only 1 port has both enabled. I’ll try that out, thanks!



  • All the ports are set to spanning tree and portfast. I’m assuming portfast is the fast STP protocol you’re referring to.


  • Moderator

    Check to ensure your switch has spanning tree turned on, AND ensure that you are using one of the fast STP protocols (RSTP, MSTP, Fast-STP, or what ever your switch manufacturer calls it).


 

432
Online

41.9k
Users

12.4k
Topics

116.8k
Posts