Attempted Multicast Broke it



  • This afternoon I attempted to push a multicast to a group. None of the computers seems to be able to connect. They would wake on lan, but then would hang loading the boot. So I decided to try to just cancel it(saw some comments on the forum about MultiCast being brokenish ATM). But now I can’t access the web interface. I get a “Gateway Timeout
    The gateway did not receive a timely response from the upstream server or application.” error when I try.

    And of course I’m working on a timeline. Anyone have any idea what would have caused this / how to fix it? I’ve tried a simple reboot a couple times, and it doesn’t seem to fix the problem.

    Philip

    Edit: Sorry, more information that would be helpful: This is the first multi cast I’ve attempted since I updated to the latest FOG a week or two ago. I have done unicasts several times as I was working on developing a new image and successfully pushed several in that process. Its running on Ubuntu server, updates current.



  • I just found this thread: https://forums.fogproject.org/topic/11713/503-service-unavailable-error/40 I’m going to try some of that stuff and see what happens.



  • So I’m getting lots of errors in the Apache Log. Here’s an example:

    [Sat May 05 04:24:15.768262 2018] [proxy:error] [pid 9948] (110)Connection timed out: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*) failed
    [Sat May 05 04:24:15.768405 2018] [proxy_fcgi:error] [pid 9948] [client 10.10.0.121:46478] AH01079: failed to make connection to backend: 127.0.0.1

    I don’t have any idea what I’m looking at/for though. The web management interface is down again and I’m getting a 503 Service unavailable error splash on that. The computers that are mid image appear to be continuing uninterupted, but the others are popping up with the same error as the web management does.

    Anyone with any ideas?



  • So it’s back to broke. I’m getting ready to dig farther into it I guess, because I need to have it working tonight. I’ll start grabbing screenshots and the such and post them here when I have them.

    Here’s to a long night.



  • So while I was waiting I ran the installer on the off chance it would fix itself. It did. I can access the web management again. The multicast still isn’t working. However I canceled it and am now doing unicasts 10 at a time. Inelegant, but it works. I’ll troubleshoot more later when I don’t have new students coming in the next 48.

    Philip


  • Moderator

    since its a ubroke2 ™ system please check the apache event log.

    But really I don’t think that is a fog error message, unless its a 503 or 504 error. Check the apache event log and if there is nothing useful then post a screen shot of the actual error message.


 

478
Online

41.7k
Users

12.2k
Topics

115.2k
Posts