PHP failed to install properly



  • I am trying to setup a clean install of my FOG server. I’m using Ubuntu 12.04 simply because I have no Linux background, and that’s the version I used on the prior FOG server and it worked. I’m following a written procedure I created when I setup the FOG server originally, so I know it’s worked in the past. After installing Ubuntu I ran all updates and upgrades before installing the FOG software. I pulled FOG version 1.4.4 from the sourceforge website. I was previously using version 1.2.0 (I think). During the installation of the FOG software I received a message that PHP failed to install properly. The installation process could not find /etc/php/7.1/apache2/php.ini. I recall at one point being prompted at the beginning of the FOG installation process that I should let it remove some PHP and Apache files, which I let it do. I’m not well versed on Linux at all, so I"m kind of lost. Any suggestions would be greatly appreciated. Thank you in advance for your time and patience.



  • @george1421 thanks for your directions. I was able to get the newest version of FOG up and running on my server. Thanks again.



  • @george1421 I installed Ubuntu 16.04.4 and then followed your steps to install the latest FOG version from github but still got the same results. The installation starts, it installs or skips a bunch of packages. I get to the end, and it tells me the Installing now everything updated has failed and it takes me back to the prompt. I also see that it failed to install the php-mysqlnd package.


  • Moderator

    @digital-dog If you are installing new, I might suggest using the git process instead of using the FOG tarball. From the error message I’m going to assume that a missing dependency is at fault.

    For the git approach your fog server needs internet access (actually even with the tarball approach it needs internet access).

    Please do the following:

    sudo su -
    sudo apt-get update && apt-get install git
    git clone https://github.com/FOGProject/fogproject.git /root/fogproject
    cd /root/fogproject
    cd bin
    ./installfog.sh
    

    This will clone the git repository and then install fog from the local repository. By using this method you can update the installer files to the latest release by issuing these commands.

    sudo su -
    cd /root/fogproject
    git pull
    cd bin
    ./installfog.sh
    


  • George,
    Thanks for your response. I’m not concerned about my images. I have those backed up to an external drive. I was attempting to do a clean install. Yes, I was using some older software, but as I stated, I did so because that’s what worked for me in the past. After posting, I tried a newer version of Ubuntu - 16.04.4 and Fog 1.4.4. At the end of the installation the very last line reads:
    Installing now everything is updated…Failed!
    So, I am at a dead end again.


  • Moderator

    Ubuntu 12.04 is very old and not supported by Ubuntu or FOG (current). Ideally you should have spun up a new fog server using a current supported OS and then migrate you image files to the new fog server. Hopefully the fog installer didn’t get far enough in the install process to break your current fog 1.2.0 install.


 

463
Online

41.8k
Users

12.4k
Topics

116.6k
Posts