FOG Randomly stopped working properly



  • Hi,
    FOG has stopped working properly, machines can’t boot up, and go past the PXE boot stage, it tries to load the FOG screen (I’ve got the hidden menu enabled, so there’s no GUI), but then says

    Could not boot: Connection reset (Http://ipxe.org/0f0a6039)
    Chainloading failed, hit ‘s’ for the iPXE shell; reboot in 10 seconds_.

    Any ideas, I’ve never had this before, I’ve also rebooted the FOG server to see if it makes any difference.

    Please help.



  • @sebastian-roth
    I’m currently creating a new FOG server as a test to see if it does the same with that, if it works fine, I’ll re-install FOG on the old server, however, as it’s a school, and staff are teaching using the PC’s that have been imaged with FOG, If I was to re-install FOG would it affect the machines if the client (the FOG Service) can’t talk to the server, IE, it’s not going to reboot or disconnect from the domain or anything?

    Thanks,

    Dan


  • Developer

    @dloudon96 said in FOG Randomly stopped working properly:

    ... Connection reset ...

    To me this sounds like some kind of low level network issue. You better get to know how to capture and read packet dumps with wireshark.



  • FOG server OS is Ubuntu 14.4 I think (Can’t remember off the top of my head).

    FOG version is 1.3.4

    Nothing at all has changed on the network, or the FOG server, so it’s odd why it’s started bringing up the chain loading message.

    Any other ideas?

    Thanks,
    Dan


  • Moderator

    @dloudon96 well that wasn’t what I was expecting. I’m not seeing anything in that ipxe menu that should be causing that chain loading eror message. What you posted should be there as far as I can tell as long as your fog server is at 10.31.97.240

    What host OS is your fog server running?

    What version of FOG are you using?

    If you re-enable the fog ipxe menu does it give us any different results?



  • #!ipxe
    set fog-ip 10.31.97.240
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    iseq ${platform} efi && set key 0x1b || set key 0x1b
    iseq ${platform} efi && set keyName ESC || set keyName Escape
    prompt --key ${key} --timeout 500 Booting… (Press ${keyName} to access the menu) && goto menuAccess || exit
    :menuAccess
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param username ${username}
    param password ${password}
    param menuaccess 1
    param debug 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain -ar http://10.31.97.240/fog/service/ipxe/boot.php##params


  • Moderator

    Ubuntu server maybe?

    from a browser see if you can navigate to this url.

    http://{fog_server_ip}/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00

    That is the ipxe menu. For you it should be very short since you have the menu hidden.

    Also inspect the apache error log for your distro. There may be useful info in the error log.


 

480
Online

41.8k
Users

12.4k
Topics

116.6k
Posts