PXE Booting UEFI and Legacy



  • We have been using FOG for about 6 months now and all has been running smoothly…well at least until yesterday lol. We received a new demo unit (Optiplex 5055) to test with and I wanted to make sure that it would work with FOG. After messing about in the Windows 8-esque BIOS, I could not for the life of me get it to see the M.2 SSD, SATA SSD, or USB when in Legacy mode to boot from. So I was left with having to re-enable UEFI and start from there. My quest led me to this Wiki to get me setup with PXE booting both UEFI and Legacy computers on Server 2012 R2. I followed all the steps and no dice, UEFI still would not PXE boot. I tried all the different UEFI architectures and still nothing. So after fiddling about I noticed that the screen capture in Step 7 was a little different from what I was seeing. I had an “Append wildcard()” box as shown and a “Prefix wildcard()” box. So ticked both boxes and finished the setup. Upon PXE booting the new machine with UEFI it worked!!! So I just wanted to share my experience in hopes that it would save someone some frustration and hair pulling. On a side note after deploying a test UEFI image, I was getting the error “Failed to set disk guid”. I found out this is related to GPT which seems to be used by default when using UEFI instead of MBR. After updating from 1.4.4 to 1.5.2 the error went away and so far everything seems to be working.



  • @ravigon Thank you very much for reporting this. Most definitely this difference is due to Microsoft changing something through a patch made public after our wiki article was initially published. I will get this updated photo into the wiki and again thanks for this! #wiki worthy.



  • Picture for reference:

    0_1524668473179_UEFI.PNG


 

478
Online

5.4k
Users

12.6k
Topics

118.7k
Posts