UNSOLVED Unable to PXE boot ESXi

  • CentOS 7 base
    Fog 1.5.2
    no other dhcp/fog servers


    Added a menu entry under iPXE for VMWare ESXi (6.5 U1). I have the contents of the cd/dvd in /images/desxi

    I have edited the boot.cfg both in /images/desxi and /images/desxi/efi/boot/ to have the prefix of my server path to the path of these files (http://ip/fog/images/desxi) and have removed all the leading ‘/’'s in the modules and in front of the tboot.b00.

    I followed this post as a guide:

    I have verbatim what they have in terms of my boot.cfg and my menu entry except I am using my paths.

    I get the entry upon boot, select it and get text saying (BIOS):
    http://ip/fog/images/desxi/mboot.c32… ok”
    Then it just sits there and does nothing. I have nethogs up and see no traffic, nothing is being xfered. It just sits at that screen.

    For UEFI its a bit different (adjusting menu entry to use bootx64.efi):
    It flashes that bootx64.efi loads/ok
    then it goes to a screen that looks like the ESXi boot up if it was vertically smashed into a smaller space and if it was a scrabbled tv signal (cant make out any of the “text”, just bands of color). It then freezes and has to be hard shutdown/startup

    I do need this to work via UEFI and BIOS, so I dont think memdisk is an option. Ive followed dozens of articles on VMwares site, articles online, searched these forums, etc. Ive tried variations of the commands both in boot.cfg and within the menu parameters with no luck.

    Any help would be great, thanks

    -PS I did get CentOS 7 working via PXE boot on multiple hosts using both BIOS and UEFI boot. So I am pretty sure things like dhcp, http, firewall, etc are configured properly. I have also tried redownloading the esxi ISO 3 times, so I doubt its the image.

  • Moderator

    [MOD Note:] Locking thread since circumstances have changed.

  • @george1421 The issue has changed drastically since posting this, likely warranting anew title and description as well. I was going to delete this topic had no one responded. I will leave it for now and post a link to my new topic. Sorry

  • Moderator

    without looking too deep into this I think you are mixing your protocols here.

    I would place your image files in /images/os/esxi or what ever, but under the /images directory on your fog server.

    Then use NFS as your transport protocols in your ipxe menu. You can get a peek at how to use the nfs protocol here: https://forums.fogproject.org/topic/10944/using-fog-to-pxe-boot-into-your-favorite-installer-images/7

    The structure would be something like this:

    initrd nfs://${fog-ip}:/images/os/esxi/kernel.bz
    initrd nfs://${fog-ip}:/images/os/esxi/initrd

    I suppose I could look into what it would take to write a post on that. It shouldn’t be “too” hard to setup. 😉