Cant boot to fog UEFI or Legacy



  • Nothing is coming up a big loop. Fog server is on the same static network as the dhcp server. this is different then the dhcp network. the server is a VM on Centos 7 fog version 1.5.0 which i also cant upgrade to 1.5.2. i added a tcpdump[0_1524244729570_output1.pcap](Uploading 100%) i can ping both devices from each other. I’m not even able to bring up a menu to register the host. Please let me know if their is anything else you need.
    file is undionly.kpxe for option 67 and 66 is the ip of the fog server. using a dell latitude E7250 secure boot is off.



  • @snaggel So we figured out the port on our switch was a trunk port. we cleared the configuration on the port. we also enabled portfast on it. we tested and it registers the host and loaded images. just wanted to let everyone know. thanks again. now on to getting it activated through KMS.



  • @george1421 Will do i will let you know what i find out. thanks again


  • Moderator

    @snaggel OK if the dumb switch masked your issue, then you need to contact your networking group to have them check to see if spanning-tree is enabled on the building switch, and then to adjust spanning tree settings to ensure that one of the fast spanning-tree protocols are enabled.



  • @george1421 Sorry for the delay. I did try a dumb switch and it worked. now figuring out what or which protocol/configuration is messing it up. thanks.


  • Moderator

    @snaggel I would say that:

    1. If your FOG server is at ip address 10.10.60.17 AND…
    2. The fog server is pingable from the subnet where the PXE booting computer is located AND…
    3. You only have one network adapter in this computer…

    My intuition is telling me that you have a spanning tree issue. This is where you have spanning tree enabled on your building switch but you are not using one of the fast spanning tree protoocls like (fast-STP, RSTP, MSTP, or what ever your switch mfg calls it).

    As a quick check for spanning tree, place an unmanaged (dumb switch) between the pxe booting computer and the building switch and see if booting works normally.



  • @snaggel im able to get to the menu but now if i try to register it i get the error below.![alt text](0_1524688077241_fog menu.jpg image url)0_1524688101150_pxe error.jpg i did rum the compatibility checker all was good. the only thing i noticed is i did not have an ip address.



  • @sebastian-roth not sure if i have a dumb switch to test with


  • Developer

    @Snaggel Please try connecting a dump mini switch between the client and your main network switch. Try again.



  • @snaggel Tried the ipxe boot loader and was getting these errors. it did bring up the menu this is after i tried to register the host. 0_1524683002021_pxe error.jpg


  • Moderator

    @snaggel Ive been looking at your pcap file again and I do find what .240 and .248 are telling the client a bit suspicious. But if its working for you, who am I to say.

    One last question. for the clients you want to image, will they be pxe booting on the 10.10.60.0/24 subnet or on another subnet?



  • @george1421 ok we do have 2 subnets. dhcp and static but both can communicate across each other. ping back and fourth. i talked to our network engineer here what he stated is those ip address 10.10.60.240 and 248 are not handing out dhcp. since we were connected to the core router and we were seeing other device asking through a switch which is what those address are. they were other switches. plus viewing traffic only on 66 67 69 ports will see that. again one dhcp server 2 subnets actually 3 for our phones. will this be an issue? im going to try the ipxe for the uefi one and see what happens as i wait for your reply.


  • Moderator

    @snaggel OK for centos 7, there is dnsmasq version 2.76 available. That is the minimum version needed to support dynamic boot files.

    I can understand having 2 dhcp server (primary and secondary) as long as each one doesn’t hand out the same IP address range. 3 is a bit strange.

    If you want to go ahead with dnsmasq then I can take you down that path. One question, do you have multiple subnets at your location? dnsmasq (as well as dhcp) can only listen for dhcp request on the same subnet where the server is located. If you have multiple subnets then you will need to make an adjustment to the dhcp helper service on your subnet router. The setup is actually rather easy to do. The risks are if the fog server is powered off, then no pxe booting. That should’t be an issue if you are only using fog for pxe booting



  • @george1421 agreed on the 10 years ago but it isnt up to me. my fog server is running centos 7. i will also be figuring out why those other 2 ip address are handing out dhcp as well


  • Moderator

    @snaggel Ugh, 2008 that’s to 10 years ago…

    There may be other options depending on what OS is running on your fog server. You could enable dnsmasq on the fog server to hand out the proper boot information.

    You might want to explain why you have 3 dhcp servers replying to this one pxe booting client. This is typically not what you want to happen.



  • @george1421 ok i checked out the WIKI has anyone been able to do this for a 2008 server? this is what we are using for our dhcp server. if this has not been working what are any work arounds then?


  • Moderator

    @snaggel typically for uefi systems you want to send ipxe.efi and for legacy/bios systems you would send undionly.kpxe.

    In your first pcap the pxe booting computer was uefi because it said it was type BC in dhcp option 93 or 94 (sorry old memory). That is what the dhcp server will use to determine which file name to send back to the client in the dhcp offer packet. In your case you have 3 dhcp servers all sending back undionly.kpxe, which will of course not be liked by a uefi system.



  • @george1421 thanks for that. also what boot loader should i use. i pretty sure i sent the pcap file with those filters first and was aked to get an unfiltered one and/or http and tftp filtered.


  • Moderator

    @snaggel I removed your pcap file. It contained way to much information that should be posted on a public forum. Please use the capture filter of port 67 or port 68 or port 69 or port 4011 to capture just the pxe booting packets.

    But again your issue is related to sending the wrong boot loader to the target computer.



  • here is the unfiltered pcap which is now a txt file.

    [mod note] pcap file was removed -Geo


Log in to reply
 

447
Online

6.2k
Users

13.6k
Topics

128.1k
Posts