Problem uploading large (4GB+) Snapin...



  • I am having an issue trying to upload a large snapin which is over 4GB. I have edited the php.ini file to allow larger file sizes, I have changed php and apache timeout settings, and nothing works. After about a minute and a half, the upload snapin page times out. I have tried different browsers, etc. I can’t get it working and I really need some help on this.



  • After hours upon hours of trying to figure out a config file parameter I may be missing, that dummy file workaround is music to my ears. Thanks a lot!


  • Moderator

    Http wasn’t meant for large file transfers and therefore none of the related technologies were either.

    My research suggests the 1.9 GB limit is due to the use of a signed 32 bit integer to hold the max upload size value. 32 bits can hold up to 4GB unsigned and 2GB signed.

    I would upload a small dummy file just to create the snap-in data in fog, then use FTP/USB to copy the real file over the dummy file.

    Otherwise you’ll have to modify the snap-in upload pages to use flash or java or something to handle the upload.

    You can also just use GPO or SCCM since you’re already n a domain when you want to install. For now, FOG can’t do the huge upload.



  • Visual Studio developer tools. I would rather have the OSes installed with just storage & network drivers, join the domain, and once on the domain let the packages be installed. I also have users who aren’t getting new machines but I still need to deploy the software to their existing Windows 7 installations.


  • Moderator

    It’s an apache/php setting. You’ll have to research it from that direction and not fog. Just curious but what is over 4gb that you are trying to deploy after imaging and not before.


Log in to reply
 

401
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.