Can't update kernel



  • I’m having issues with updating the kernel i successfully download the file but i get
    “/var/www/html/fog/lib/hooks/submenudata.hook.php, Line: 74, Message: Undefined index: node, Host: 10.5.0.19, Username: fog” i went to that config file but i dont know how to put the correct text in to correct the issue



  • @george1421 Yes that fixed it! and yes i realize that both these errors imply that someone messed with my server. I may have unintentionally done it myself but i dont know when. i’m also doing all of this in a votech class room with immature high schoolers around and they may have screwed with something. doesn’t really matter though, its fixed ad i thank you for helping me sir.


  • Moderator

    @jfulton ok now that we have the fog password set. Please ensure that you have a /home/fog directory. If not please do the following.

    1. mkdir /home/fog
    2. chown fog:fog /home/fog

    Then try to log in again via ftp.

    You know, coupling this error with your original one, its almost as if the linux user fog wasn’t created correctly or someone changed its configuration.



  • @george1421 okay i used passwd and set the same password there as i did for .fogsettings and the master fog server storage node and the TFTP server settings. then i attempted to log in remotely from windows and got
    “cannot change directory:/home/fog
    Connection closed by remote host”

    when i try to update the kernel i get
    “Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 463, Message: ftp_login(): OOPS: cannot change directory:/home/fog, Host: 10.5.0.19, Username: fog”
    i have both SELinux and Firewalld disabled


  • Moderator

    @jfulton ok lets just focus on one thing your master FOG server.

    So from a windows machine you can not log into your master fog server using the user ID of fog and the password found in the .fogsettings file. That right there is going to be a problem for you. I’m going to also assume that you can not log into the fog server via putty with the same user ID and password. If this is the case then we need to fix the linux fog user’s password. Be sure to write down the password from the .fogsettings file. Then log into the fog server as root or su to root. Then key in passwd fog for the password use the password from the .fogsettings file. Once that is set then confirm you can log into the fog server using ftp from a windows client. Hopefully that will be a yes.

    Now go into the webui fog settings and ensure the password field there (2 places) contain the password from the .fogsettings file. Lastly go into the storage node settings for the master fog server and ensure the management password there matches the .fogsettings file. At this point everything should be back in sync.



  • @george1421 just tried to ftp into my server and it failed. i got the username and password the same in .fogsettings, TFTP server options and storage node management options (i only have 1 storage node). still cant update kernel


  • Moderator

    @jfulton Ok what you need to do now to ensure things are setup correctly.

    1. From a windows computer use the ftp command and ftp to each fog server using the user ID of fog and the password from the .fogsettings file on each server. If that works then go to step 2.
    2. Go into the web gui storage node management. Ensure the password listed for that storage node (both master and storage ndoes) match the .fogsettings file from each respective server.

    If both of those are in sync then you should be back in business.



  • @george1421 I only have 1 storage node and I copied the password there as well. all passwords should be the same now


  • Moderator

    @jfulton In addition to the fog settings password, you need to go into the storage node 10.5.0.19 and insure you have the password set there too.

    Understand that if you have a FOG server and storage nodes, each storage node has its own .fogsettings file and the password that is unique to that storage node. In that case you would only need to ensure the storage node values in the webui are correct. The FOG master node would need the fog settings updated.



  • @george1421 i followed the tutorial step by step just now. i copied the password from /opt/fog/.fogsettings into the management password field and the TFTP FTP Password field in the WebGUI.


  • Moderator

    @jfulton ok you messed up the passwords by? Reinstalling fog or following the tutorial?



  • @george1421 ok i guess i screwed my entire server up because i reset all the passwords on storage node and tftp server and now i get
    “Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 463, Message: ftp_login(): OOPS: cannot change directory:/home/fog, Host: 10.5.0.19, Username: fog”


  • Moderator


  • Moderator

    @jfulton You can reinstall if you want, or you can fix it. That is up to you.



  • @george1421 im really not sure. i certainly didnt mean to. im attempting to reinstall now


  • Moderator

    @jfulton It would appears that someone has changed the linux user fog password on host 10.5.0.19. The linux user fog is a service account used by FOG (only). Might you have changed/reset this password after FOG was installed?



  • now im getting
    “Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 463, Message: ftp_login(): Login with USER first., Host: 10.5.0.19, Username: fog” can someone please help?



  • I think the issue is with the way i have the IP address configured because i also have issues with PXE booting. also the wiki page on tftp didnt help much at all



  • i am using fog 1.5.2 on fedora 26




 

576
Online

5.4k
Users

12.6k
Topics

118.7k
Posts