Upgrade to 1.5.2 can't copy binaries where needed



  • When I try to upgrade to 1.5.2 it always fails with:

     * Copying binaries where needed...............................Failed!
    

    Where do I need to look to figure out this problem?



  • @librarymark Looks like the binaries failed to download, which caused the later error you are seeing when it tries to unzip & move them to the right spots. Look earlier in this log, you should find an error related to the binary downloading.



  • Here is the tail end of the fog_error file:

    ● mysql.service - MySQL Community Server
       Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
       Active: active (running) since Mon 2018-04-23 08:07:40 EDT; 2s ago
      Process: 31338 ExecStartPost=/usr/share/mysql/mysql-systemd-start post (code=exited, status=0/SUCCESS)
      Process: 31328 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS)
     Main PID: 31337 (mysqld)
        Tasks: 29
       Memory: 139.2M
          CPU: 274ms
       CGroup: /system.slice/mysql.service
               └─31337 /usr/sbin/mysqld
    
    Apr 23 08:07:39 fog-server systemd[1]: Starting MySQL Community Server...
    Apr 23 08:07:40 fog-server systemd[1]: Started MySQL Community Server.
    ERROR 1396 (HY000) at line 1: Operation ALTER USER failed for 'fog'@'127.0.0.1'
    Archive:  binaries1.5.2.zip
      End-of-central-directory signature not found.  Either this file is not
      a zipfile, or it constitutes one disk of a multi-part archive.  In the
      latter case the central directory and zipfile comment will be found on
      the last disk(s) of this archive.
    unzip:  cannot find zipfile directory in one of binaries1.5.2.zip or
            binaries1.5.2.zip.zip, and cannot find binaries1.5.2.zip.ZIP, period.```


  • @librarymark said in Upgrade to 1.5.2 can't copy binaries where needed:

    Where do I need to look to figure out this problem?

    In the bin directory where the installfog.sh is, you’ll find a new directory with all the error output from the installer in it. The actual error will be in there typically at the bottom.


 

435
Online

5.4k
Users

12.6k
Topics

118.8k
Posts