FOG 1.5.2 Canges in FOG-Settings will not be stored and AD-Settings are wiped out



  • Hello!
    After updating from 1.4.4 to 1.5.2 (without any problems), now in 1.5.2 every change I made in the Fog Settings will not be stored.
    For example changing the PXE MENU TIMEOUT from 5 to 3 is quited with “settings successfully stored” but when I change to the Dashboard and go back to Fog settings the old entry is shown.
    And thats not all: the entries in Active Directory were wiped out (I never made any changes here) and cant be stored again though it says “settings successfully stored”.
    Any Ideas?
    Greatings
    Bodo



  • @tom-elliott Hello Tom! I know that. But you misunderstand me!
    What I do is the following:
    I change an entry under “Active Directory” and press “Update” in this section -> Feedback: “successfully saved”.
    If I then go to any other menu item in the FOG (e.g., Dashboard) and back to the “FOG Settings” to “Active Directory”, the changes made will still be there!
    If I now change another item in the settings (for example, PXE MENU TIMEOUT and change the value 5 to 3) and press Update under this section, appears again “successfully saved”.
    But if I switch to the dashboard and go back to the FOG settings under “Achtive Directory”, the entries made there have disappeared and also the change in the section above it (in PXE MENU TIMEOUT is again stored 5 instead of 3!)!
    Printscreens:
    First Change in Active Directory:
    0_1528959423881_1-first_change.jpg

    Press update:
    0_1528959483221_2-success.jpg

    Going to dashboard and back to FOG-Settings changing “PXE MENU TIMEOUT from 5 to 3” and press update:
    0_1528959526220_3-second_change.jpg

    Going to dashboard and back to Fog-Settings, all changes are gone!!:
    0_1528959638221_4-go_to_dashboard_and_back_to_settings.jpg


  • Senior Developer

    @bb-ikt the fog settings currently requires you to press the update button for the category you’re working in. Pressing enter will give a success but won’t actually update anything. It doesn’t not support multiple section updating currently either, meaning if you edit multiple categories and choose update only the section containing that update would be stored. This is inconvienent but was intended to help prevent accidentally zeroing out data as those items are relatively important.



  • @tom-elliott Ubuntu 16.04.4 LTS and Fog Server 1.5.4


  • Senior Developer

    @bb-ikt what os is the fog server



  • @quazz hmmm., sorry, no such log, neither in the Web-Gui, nor in the /var/log/ and subdirectories…


  • Moderator

    @bb-ikt Repairing them was important for many reasons not just for this specific problem.

    On the FOG WebUI there should be a second PHP-FPM log file (www-error log), does that contain anything useful?



  • @quazz I do the “sudo mysqlcheck -r fog”
    With this reply:
    0_1528900646611_check-database.txt

    but it did not solve the problem unfortunately! :-(



  • @tom-elliott Hy Tom! I understand! Will the new logfile again have the “wrong” permission when logrotate starts? Where can I set with which permissions the new logfile will be created?

    But back to the main problem:

    My problem is not the wrong permissions on the logfiles, but that settings in the fog settings are not saved.
    For this I have new findings:
    If I enter something in the fog settings under “Active Directory”, these entries are saved. But if I change something in the “FOG System Settings” afterwards (for example the menu timeout from 5 to 3) the entries in “Active Directory” will be deleted! That is reproducible.


  • Moderator

    @bb-ikt It looks like some of your tables in the database have crashed.

    sudo mysqlcheck -r fog
    

    should hopefully repair them


  • Senior Developer

    @bb-ikt logrotate changes them. On a cycle the permissions are reset to whatever it’s configured for. When this rotation occurs, it resets the file ownership and permissions.



  • @quazz I changed the pm.max_children entry in /etc/php/7.1/fpm/pool.d/www.conf to 50
    new PHP-Log:
    0_1528889085857_FOG-PHP71-fpm_2.txt

    I also changed permissions to 755, so now I can see the apache-log-files in the GUI!! (but I do not know how this permissions could change, nobody has ever changed them??)

    Here the mysql log:
    0_1528889995333_sql-log.txt

    and actual Apache log:
    0_1528890400238_FOG-APACHE2_2.txt


  • Moderator

    @bb-ikt

    How or where do I change the PHP-FPM settings?

    I don’t know by heart where to change it on debian based systems.

    You can likely find out by doing something like grep -r pm.maxchildren /etc

    Your permissions in the log folder make it so you can’t view logs in the Web GUI. chmod -R 755 var/log/php-fpm should resolve that hopefully (unless they’re being created with the wrong permissions, which would indicate a configuration issue in apache)

    You can find the mariadb log under /var/log/mysql on debian based systems I believe.



  • @quazz Thanks for reply!
    How or where do I change the PHP-FPM settings?

    here are the current permission-settings of the Apache2-logfolder:
    0_1528886769897_FOG-APACHE2_log_permissions.txt

    Where do I find the mariadb-logs? Here are the files and folders in LOG:
    0_1528887322547_log-folder.txt

    Strangely enough, the other described problems (kernel update and version information) have been done as if by magic (I have not changed anything, but these two things are working again!) !?


  • Moderator

    @bb-ikt Alright, so the reason you couldn’t view the logfiles was because of permissions problems. (you can check them with ls -lah /var/log/httpd (or apache2 on debian/ubuntu I think) permissions should be 755 (rwx r-x r-x)

    I can also see your PHP-FPM max-children is set to 5. This is very low for most scenarios. I believe in FOG it’s currently set to 50.

    I don’t see anything to explain your original problem adequately, however.

    Can you try the actions you mentioned and see if anything new shows up in the logs? If nothing shows up you can also check the mariadb logs.



  • @quazz I really would if I could…, Apache ErrorLogfile says: “Unable to open file for reading”
    So I connected to FOG via SSH and open the logfiles PHP-FMP and apache errorlog.
    You will find the copied content attached

    0_1528816009808_FOG-APACHE2.txt

    0_1528816020869_FOG-PHP71-fpm.txt


  • Moderator

    @bb-ikt On the FOG WebUI there is a Log viewer under FOG Configuration.

    I’m guessing there are some relevant errors under the PHP-FPM and/or Apache logs if you could paste them here.



  • @quazz Thanks for response!
    I already updated to 1.5.4 this morning, but this hasn`t changed anything.
    Server OS: Ubuntu 16.04.4 LTS running as VM (8cores, 4GB) on a Hyper-V Host W2016
    Client OS: WIN 10 x64
    Browser: Firefox 60

    The problems startet with the update from 1.4.4 to 1.5.2

    Today I found some more strange behaviors:
    FOG version Information does not show the actual versions, but after a minute doing nothing: “failed to get latest info”
    Kernel Update does not show any kernel, but also after about a minute doing nothing “504 Gateway Time-out”

    I am IT-admin in three schools, two of them have FOG 1.5.2 (1.5.4) with the same issues and one has 1.4.4 withou any issues, all installations are done in the same way (Hyper-V)

    please be lenient with my bad english and also my Linux skills are not the very best…!


  • Moderator

    @bb-ikt Sorry for the lack of response.

    I recommend updating to 1.5.4 and see if that helps already.

    Please get back to us if it still occurs in 1.5.4 (and provide info such as Server OS, client OS, client browser)



  • Hy!
    No one who has the same problem, or can help me with this issue?
    Today I updated to 1.5.4 with the same result, that some changes in fog-setting will not be stored!
    Is there anything I can do, to get more information on this problem?
    regards
    Bodo


Log in to reply
 

447
Online

6.2k
Users

13.6k
Topics

128.0k
Posts