SOLVED Service Settings revert to "all unchecked"

  • Hei.

    Yesterday I updated our Ubuntu 16.04 Server to FOG 1.5.2 - no errors during update.

    Since then, one of the computers that was imaged about a month ago keeps loosing the checked boxes in the “Service Settings” area of the hosts menu. As a consequence the log file on the client shows: The response module is disabled on the host - and the fog client doesn’t do its deeds.

    Curiously, one of the checked boxes stays checked, but which one keeps changing, I wasn’t able to find a pattern yet.

    The service settings are all set as required in the FOG Settings Menu, so those shouldnt overwrite anything.

    Tried repairing the FOG client, it is up to date - tried uninstalling and reinstalling - no change.

    For all the other computer in use, I haven’t found one so far that shows the same error - but I am afraid it might come back and bite me when I don’t expect it 🙂

    Anybody has an idea what could be wrong?

  • Oh, I had a look around but somehow seemingly didnt use the right querys to find the other threads. Sorry.

    It is on a host, the host was registered long before 1.5.2 and the last imaging was done before 1.5.2 as well.

    Reproductability is the problem atm, no other host shows this behaviour. I was thinking about just re-imaging and hoping it would go away.

    Things we did do:

    • Delete Macs that werent from the main Network card.
    • Reset Encryption Data
    • Saved the settings without any boxes checked and then tried saving with boxes checked.

    But regarding what you wrote it seems its not in the communication part between fog and the fog-client right?

    Sorry, not much more I can give. Will hang tight, thanks for your great work.

  • Is this on a host, or group? Can you give me a detailed, as much as possible, of how I can reproduce? If I can reproduce it reliably, I can usually fix it pretty quickly.

  • @taspharel 1.5.2 has some problems with saving settings, there’s a few threads open about this. All I can say is sit tight for now.