Windows 7 and Windows 10 simultaneously



  • I have tried finding the answer for this in the forum and google. Hope I am not repeating a question but here it goes.
    We have been using Fog in our office for some years now, we have a schedule set to capture each machine over night and it has been working wonders. However we recently had two machines upgrade to windows 10. The capture task for these had to be canceled because Fog wasn’t working with windows 10.
    I was able to figure out that the reason Fog wasn’t working with windows 10 machines is the bootfile. We are currently using “undionly.kkpxe” and it works fine with windows 7 machines. However I was able to get windows 10 machines to work with “ipxe.pxe”.
    It would be perfect if I can specify my DNSMasq to use either or bootfiles but I am not sure if that is possible. My current DNSMasq Options are
    “dhcp-boot=undionly.kkpxe,192.168.xx.xx”
    If anyone has any idea how I can have this work on both OS or knows of any other backup solution that would work please let me know. Thank you in advance.



  • @george1421 Thank you for all the info I am going to start working on this.


  • Moderator

    @gnavarrete Yes you can. You can use any of the bios boot kernels in the bios spot and the uefi ones in the uefi spot. If you need certain boot kernels for certain hardware, we can do that too. But you need to have the right version of dnsmasq to start.



  • @george1421 said in Windows 7 and Windows 10 simultaneously:

    dhcp-boot=undionly.kpxe

    Sorry this might be an obvious question but I just want to make sure. I am guessing that I can change the “undionly.kpxe” instances to “undionly.kkpxe” since that is what is currently working for all of our windows 7 machines right?


  • Moderator

    @gnavarrete I think you have posted the best path forward. Create a second FOG server, copy the images over and export and import the image meta data and hosts. https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG

    as for the dnsmasq, the link I provided before has a working ltsp.conf file. I’ll repost it here. Just don’t forget to change the <fog_server_ip> to the fog server real IP address.

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,<fog_server_IP>
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI,ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI64,ipxe.efi,,<fog_server_IP>
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=<fog_server_ip>,proxy
    


  • @george1421 Thanks for all your help. I think I am going to install the new version of Ubuntu on another machine, install fog from scratch and mess around with the DNSMasq to see if I can get it to dynamically shift. Is there any recent posts that you may have on how to achieve this dynamical shifting?


  • Moderator

    @gnavarrete I’m only here to provide options. Do what is the best for you and your company. I agree with moving off 14.04 since its past EOL anyway.



  • @george1421 I was reading through your post (very nice post by the way). The only thing running on that server is Fog I wouldn’t mind upgrading the version to get the 2.76 v available in the repository.


  • Moderator

    @gnavarrete Not the OS I wanted to hear. You can try to see if 2.76 is available in your ubuntu repository, but I double it. You may have to compile your own: https://forums.fogproject.org/topic/8725/compiling-dnsmasq-2-76-if-you-need-uefi-support

    Edit: I just checked and you need to be running ubuntu 17.04 to have native support for the version you need: https://usn.ubuntu.com/3430-1/
    So self compiling is your only option if you want dynamic support between uefi and bios systems. If you have a windows 2012 server, that supports dynamic dhcp settings too.



  • @george1421 I have Ubuntu 14.04 running on the fog server.


  • Moderator

    @gnavarrete The version of dd-wrt is too old to support dnsmasq 2.76. So using your fog server is the next steps.

    What version of linux do you have on your fog server?



  • @george1421 This is a small office with about 13 workstations. This is the router info: Router Model Netgear WNDR4000
    Firmware Version DD-WRT v24-sp2 (06/08/12) big - build 19342

    I am not seeing a version of the dnsmasq anywhere


  • Moderator

    @gnavarrete Is this for a home lab or a business?

    You might be better off if you removed the dhcp boot options from dnsmasq on dd-wrt and install dnsmasq on the FOG server. On the fog server you will configure dnsmasq to act as proxydhcp server. Your IP addresses will still be issued by dd-wrt, but then the fog server dnsmasq will reply with the boot information.

    I’m not sure of a way to tell what version of dnsmasq that dd-wrt is using. If its 2.76 or later then we have options, and you won’t need to install dnsmasq on the fog server.



  • @george1421 Here is an image of my dd-wrt services configuration from the router. I think this would help you understand the current configuration (this is currently working with windows 7 machines but not windows 10)

    0_1522948271292_DWRT.JPG


  • Moderator

    @gnavarrete do you have direct access to the dnsmasq configuration file?

    Also what version of dnsmasq are you using. i.e. from a linux command prompt (I understand dd-wrt) dnsmaq -v Version 2.76 contains the support to dynamically shift between uefi and bios clients.



  • @george1421 I hope I am understanding you right but my DNSMasq settings are running with a dd-wrt routter which also serves as the DHCP server.


  • Moderator

    The answer is… it depends.

    Are you running dnsmasq for a proxydhcp server?
    What is your main dhcp server?

    There is a way to do what you want, I just want to ensure we go down the right path.


 

519
Online

5.4k
Users

12.6k
Topics

118.6k
Posts