Fog Server v1.5 ~ Dell Optiplex 3050



  • Hello All, I am new to the fog project so please be patient. I setup Fog v1.5 on a Ubuntu server. I have been able to image and deploy a Dell Optiplex 980 without issues. However, When I try to boot the Optiplex 3050, it looks for the pxe boot but then immediately goes to the Dell diagnostics screen. I have tried different settings in the bios as well as different kernels in the Fog Project but I am having no success.

    I am hoping that by posting here, some Fog guru can point me in the correct path to succeed.

    Hyper-V Host - Server 2016
    Ubuntu Server - 16.04.4 LTS
    Fog Project v1.50

    PfSense Router

    • TFTP Server --> Points to Fog Server IP
    • Network booting enabled --> Points to Fog Server IP
    • Default BIOS file name: undionly.kpxe

    Dell Optiplex 3050
    UEFI Bios
    Windows 10 64 bit

    Please let me know if you need any further information to assist me in my troubles.

    Best Regards,
    BIgsease30



  • @george1421 Thank you so much! This has resolved my issue.


  • Moderator

    @bigsease30 Yeah what you have is wrong. It should look like this:
    0_1522850974316_dhcp_dual.png



  • Thanks for the reply’s. I have updated the entry “undionly.kpxe” with the new “ipxe.efi” and it continues to do the same thing, boots to Dell diagnostic.

    Yes, The PC is using UEFI instead of Legacy. Attached you will find a screenshot of our PfSense entry’s. I have also tried entering the “ipxe.efi” name in the UEFI 32 and UEFI 64 bit file name fields with the same results.

    PFSense Screenshot
    Screenshot


  • Moderator

    As @phil-dosi said. You need to add ipxe.efi in the uefi field in pfsense. You did fill out the undionly.kpxe for the bios clients and you did see a bios (legacy mode) computer boot just fine. UEFI based computers will not boot with the bios boot loader (undionly.kpxe). PFSense is smart enough to know which kind of target computer you are booting, and if provided the right information to send.

    Also what phil mentioned. You must have captured a uefi windows image to be able to deploy that image to a uefi target computer. You can not mix the image styles. A bios (mbr) image can not be deployed to a uefi computer as well the other way around a uefi image will work only on a uefi target computer.



  • Hello,

    Have you try with the other BIOS file name ?
    filename “ipxe.efi”;
    your image is an UEFI ??

    best


 

323
Online

41.6k
Users

12.1k
Topics

114.4k
Posts