Dell OptiPlex 7050 Hard Drive not Found



  • Hello,

    Been struggling to get a series of Dell OptiPlex 7050’s with PCIe M.2 drives to work properly with FOG. The only way I can get the PXE loader to recognize the drives is switch the Boot Options to Legacy rather than UEFI. Secure Boot is turned off when Boot Options are set to UEFI. Running Fog 1.5 with Kernels 4.15.2.

    These systems were purchased in Feb '18. They are running BIOS 1.8.2.


  • Moderator

    @hullabaloo said in Dell OptiPlex 7050 Hard Drive not Found:

    I suspect it’s the undionly.kpxe file that I’m using?

    Well that IS what I wanted to know. That is the wrong boot loader for uefi. You need ipxe.efi (or any of the .efi) boot loaders. Change your boot loader and the uefi client should boot.

    If you were using a windows 2012 or newer dhcp server or a dhcp server that understood the differences between bios (legacy mode) and uefi it could send the proper boot file name based on the pxe booting client. Then you could dynamically switch between uefi and bios target systems.



  • Secure Boot is Off. I promise and I hope I’m smarter than that. :-) Time will tell I guess.

    But, I will admit, I know next to nothing on iPXE, UEFI boot and FOG. This is my first go at it. I was able to image (capture/deploy) multiple times on this setup to systems that used Legacy ROMs and PXE. I’m probably making some seriously wrong assumptions about iPXE. And I apologize if I’m asking some very noob questions. Just not finding information quickly in the WIKI around troubleshooting this particular error.

    So, I’m using a Ubiquiti Security Gateway for the DHCP server. I’ve used both Windows DHCP, and other Firewall stacks and all have worked. I suspect it’s the undionly.kpxe file that I’m using?

    And it’s not network. I’ve got an unmanaged switch sitting between FOS and the host in question so all traffic stays local except for the DHCP ARP packet.


  • Moderator

    @hullabaloo Ok so my initial reaction is this.

    1. You have secure boot turned on still.
    2. You are sending a boot loader that is incompatible with uefi.

    So tell me, what exactly do you have configured for dhcp options 66 and 67?

    What device is your dhcp server?



  • Boot mode is UEFI with Secure Boot Off. ACHI is turned on, with RAID off. When I select the Boot Options menu when the PC begins it’s BIOS POST, my boot options under UEFI BOOT are Windows Boot Manager, Onboard NIC (IPv4) and Onboard NIC (IPv6).

    When I select Onboard NIC (IPv4) I get the following:

    Checking Media Presence
    Media Present
    Start PXE over IPv4
    Station IP address is 192.168.1.251

    and then the screen flips so fast I had to video it so I could capture what happens next…

    Checking Media Presence
    Media Present
    Downloading NBP files…

    and then…

    Press F1 key to retry boot
    Press F2 key to reboot into setup
    Press F5 key to run onboard diagnostics


  • Moderator

    @george1421 On our 7050 purchased in fall of last year (skylake) firmware 1.5.2, fog boots correctly in uefi mode. All I changed in the firmware is was turn off secure boot. FOG boots via iPXE into the iPXE menu and runs the fog compatibility without issue (exception of the disk, which I noted previously). I also have FOS (the linux OS that captures and deploys images on the target computer) on a USB stick. That boots without issue.

    Please confirm that you have secure boot disabled. Also where exactly does the uefi boot fail?


  • Moderator

    @hullabaloo The target system should boot into FOS, but unable to see the hard drive. I have a 7050 in inventory, I’ll grab it in the AM and confirm it boots with FOG. I have FOG 1.4.4 on my production server, but 1.5.0 should be the same, I have just a bit older kernels on 1.4.4.



  • OK, tried that and what I see now is the UEFI boot fails with no error message.


  • Moderator

    change the disk mode to ahci instead of raid-on. Once the system is imaged you can switch the disk controller mode back when you reenable secure boot.


 

579
Online

5.4k
Users

12.6k
Topics

118.9k
Posts