Invalid user after schema creation



  • Hi,

    I’m setting up FOG on a debian squeeze (6.0) but I ran into issues.
    I arrived to the point I can open the web interface to set up the schema on the database.
    When I click on the button to create the schema, it throws me an error:

    Database error: (ID# 15-18)
    Database Error:
    Access denied for user ‘focuser’@‘localhost’ to database ‘fog’

    What is weird is when I log in on the DB using ‘foguser’ as user (using mysql command line) is that I can see a bunch of tables created so the credentials must be right. If I try to run it again, it gives me another error about an existing column.

    I searched in the wiki and I tried to debug with a user in the IRC channel but we couldn’t figure out what was wrong in the configuration.

    Would you have any idea where I should look to fix the issue? Or maybe is there a flag to force it to think the DB schema is done somewhere in a file or in the DB?
    Is there any way I can debug this problem? Is there any flag to enable debug?



  • I blew the installation and set up Ubuntu 10.4 and it worked fine.

    The only difference with the Debian is that I set up a password for the root user for MySQL on Debian (and created a user that was granted all rights to the whole DB; and provided that information in the fog config file as explained).

    Thanks anyway :)



  • Sorry, mistyped, it’s ‘foguser’.

    Yes. It wouldn’t have created the database (partially) if it wasn’t there.

    By the way, here is a list of the tables it created. I don’t know if it’s complete or not:

    [FONT=courier new]mysql> show tables;[/FONT]
    [FONT=courier new]±-----------------------+[/FONT]
    [FONT=courier new]| Tables_in_fog |[/FONT]
    [FONT=courier new]±-----------------------+[/FONT]
    [FONT=courier new]| aloLog |[/FONT]
    [FONT=courier new]| clientUpdates |[/FONT]
    [FONT=courier new]| dirCleaner |[/FONT]
    [FONT=courier new]| globalSettings |[/FONT]
    [FONT=courier new]| greenFog |[/FONT]
    [FONT=courier new]| groupMembers |[/FONT]
    [FONT=courier new]| groups |[/FONT]
    [FONT=courier new]| history |[/FONT]
    [FONT=courier new]| hostAutoLogOut |[/FONT]
    [FONT=courier new]| hostScreenSettings |[/FONT]
    [FONT=courier new]| hosts |[/FONT]
    [FONT=courier new]| images |[/FONT]
    [FONT=courier new]| imagingLog |[/FONT]
    [FONT=courier new]| inventory |[/FONT]
    [FONT=courier new]| moduleStatusByHost |[/FONT]
    [FONT=courier new]| multicastSessions |[/FONT]
    [FONT=courier new]| multicastSessionsAssoc |[/FONT]
    [FONT=courier new]| nfsFailures |[/FONT]
    [FONT=courier new]| nfsGroupMembers |[/FONT]
    [FONT=courier new]| nfsGroups |[/FONT]
    [FONT=courier new]| plugins |[/FONT]
    [FONT=courier new]| printerAssoc |[/FONT]
    [FONT=courier new]| printers |[/FONT]
    [FONT=courier new]| schemaVersion |[/FONT]
    [FONT=courier new]| snapinAssoc |[/FONT]
    [FONT=courier new]| snapinJobs |[/FONT]
    [FONT=courier new]| snapinTasks |[/FONT]
    [FONT=courier new]| snapins |[/FONT]
    [FONT=courier new]| supportedOS |[/FONT]
    [FONT=courier new]| tasks |[/FONT]
    [FONT=courier new]| userCleanup |[/FONT]
    [FONT=courier new]| userTracking |[/FONT]
    [FONT=courier new]| users |[/FONT]
    [FONT=courier new]| virus |[/FONT]
    [FONT=courier new]±-----------------------+[/FONT]
    [FONT=courier new]34 rows in set (0.00 sec)[/FONT]


  • Moderator

    Focuser or foguser?

    Do you have a password in MySQL for the fog user? If so, did you update the config file?


Log in to reply
 

429
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.