Fog will not PXE BOOT



  • ![I am running on ubuntu 16.04. I have fog running on another laptop and images computers fine. I have checked the services and they were up and running.

    I did have to update the dhcp server because the file did not have the correct lines added. It was all commented out. I then look into the service and it started to run. I still can not get pxe . Sql is working. I was able to log into the fog server after i static assigned IP address. Then i looked into the TFTP settings in fog and saw that was wrong. I changed it to a couple different things. It had an extra “/” in the settings.

    This is hooked up to a small switch. As i said earlier it is working on a laptop with 14.04 ubuntu desktop with no issues at all. It is the same setup. Just the newest version I can not get it working correctly. I do not even get the PXE answering.

    I have disabled the firewall from startup . Not sure where else to check . I am not sure what files to upload but here are some screenshots

    i have noticed that some of the folders that i see on the other fog server - tftboot and some others - are not on the root of the computer. But nested in another folder. Is this a botched install ? I ran installfog.sh again but folders never created.
    Here are the images

    https://ibb.co/iXyjqS
    https://ibb.co/gkJjqS
    https://ibb.co/hH7zPn
    https://ibb.co/jbuqVS


  • Moderator

    With a quick teamviewer session this issue has been resolved. The issue was just the sequence of install and ensuring eth0 was up before installing FOG.



  • @george1421

    i swear i can not win. I had a talk to management and we have to use ubuntu desktop. I am unable to get it to start.

    I am not sure but at the end where it is checking web services it fails. I went back to the ubuntu that is working on the laptop. I am installing newest version and that is the only spot it fails.

    I have a second network adapter . i went through the normal install and choose no for router portion. i assigned an ip address and made the fog server dhcp and dns. Everything appears to install but the starting and checking status of web services fail.

    not sure where to go from here


  • Moderator

    @mmoore5553 When you get the second nic installed let me know and I will give you the instructions. The setup is not hard you need to know the name of your physical ethernet adapter (eth0 or what ever your kernel calls it) and then set a default route on your second nic pointing towards the internet. Ensure your physical LAN adapter has a static IP address set for the imaging network. And finally use the git method of downloading the installer files. During setup the installer will ask you for the name of your imaging network adapter (not in those words) you just need to ensure its your physical LAN network adapter name. The rest will be installed correctly.



  • @george1421

    the problem is that i have installed linux over 2 times and then the same files and folders never exist. I will try with the second nic card as maybe that is the issue.

    i do not know why .fogsettings file and the tftp folder is missing on both new installs.


  • Moderator

    @mmoore5553 I would agree, the hidden file is create in /opt/fog called .fogsettings (the dot in the beginning of the name makes it hidden). If that file does not exist then the FOG installer did not complete. So you have a botched install.

    Recommendation: If you were to reinstall the FOG server, use debian instead of ubuntu. Connical has been doing some bad things with ubuntu lately causing us pain. Ubuntu is based on Debian so all of the install commands work the same.



  • @george1421

    Now here is the problem that i have …

    I go into computer and then look at all the folders and files.

    I do not have /tftpboot

    I do not have anything under /opt/fog. No folders or files listed under there.

    I do have the dncpd.conf

    that is why i thought i had a bad install. I see the on the old fog server on the laptop. Those locations are there. I install fog under the root admin. I always enable that and do all installs under root in ubuntu. Forced habit of seeing files failed in other software.

    That is what got me wondering why the files where gone. I can find them under /var/lib/tftpboot and the .fogsettings I can not find at all.

    i am able to go to the ip address and open up the gui with no issues.

    i am using 1.05 install and follow same instructions on the wiki . I wanted to be sure i was not going crazy .


  • Moderator

    @mmoore5553 You can fix what is there now, and then add the usb network later. Its just easier to do it in the beginning. But reinstalling to just fix what is wrong is more effort than fixing it.

    You will need to edit the following files to fix what has been changed.

    Correct the fog server IP address here:
    /opt/fog/.fogsettings
    /tftpboot/default.ipxe
    /etc/dhcp/dhcpd.conf

    Then in the webgui you need to go to the fog configuration settings. Pick the Expand all options and then search for the old fog server IP address, change and then save the settings. I think its in 3 places under fog settings.
    Lastly in the storage management -> default storage node you need to fix the IP address there too.

    It should take you about 10 minutes to fix then reboot the fog server.



  • @george1421

    That sounds like a good idea. I will go ahead an get a usb to network adapter. I have one at home for the nintendo switch. I will install linux and run the install again. I assume I would just setup and pick the network card in the settings ?


  • Moderator

    @mmoore5553 Well you have a mess to clean up ;-)

    Well not really. FWIW if you want to have a dedicated imaging network but have fog able to reach the internet for installation (only needed for that) then its ideal if you install a second network adapter in your fog server. When you install fog you will tell it to only image using network adapter X while network adapter Y has internet access to download the required files. Once the files have been downloaded you can unplug the second network adapter until you need to update fog, if you have security concerns. Or you can use the second network adapter for FOG management. That bit is up to you.

    If this is possible in your environment I can guide you on how to set it up.



  • @george1421

    yes i change the ip address since it requires internet when it first installs.


  • Moderator

    @mmoore5553 So then there is a possibility that the FOG server’s IP address/subnet mask has changed?



  • @george1421

    just upper management says it is in isolated network. I have it hooked to internet and download everything and then i go under network and interfaces file and static set the ip address . I only have one network card .

    we have a lab where we take all the computers and reimage them.


  • Moderator

    @mmoore5553 So fog is on an isolated imaging network.

    To install fog you need to have internet access. That is a requirement if you install from git or the tarball.

    FOG does not like it if you change the fog server’s IP address after fog is installed. If you do change the IP address then fog will break. Its possible to fix, we just need to know this happened.

    What is your logic to have fog on an isolated imaging network?



  • @george1421

    oh how horrible of me. I am sorry i should have put that information.

    1. the fog server will be dhcp and dns
    2. we have a small switch and same vlan.
    3. this is an isolated network
    4. This is the odd part. I am beginning to think this is not pxe but dhcp. I do not get any error message. I do not get anything on the screen. It just goes to no boot device. If i take my laptop which i have fog installed it will boot right away. This is an older version of fog. I am trying to get a desktop version to set up in a location.

    I have checked and dhcp service is running and other services are running

    I have reinstalled linux and fog twice and the same results.

    I thought since i was missing the folders on the root of C that i got a bad install.


  • Moderator

    This post is deleted!

  • Moderator

    OK lets start out with some basics.

    1. What device is your dhcp server?
    2. Is your fog server and target computer on the same subnet (vlan)?
    3. Are you imaging computers on your business network or on an isolated imaging network?
    4. When you say you can’t pxe boot, what is the error number/message displayed on the target computer?

 

372
Online

41.8k
Users

12.3k
Topics

116.0k
Posts