FOGBackup.sh returns Failed on DB backup



  • Using the latest FOG 1.5.0 on CentOS 7 server, tried to run the FOGBackup.sh script as root. The script fails on the DB backup portion of the script.

    Command used:
    ./FOGBackup.sh -B /mnt/nfs/fog
    Dirs are created and all else looks OK until the DB Backup.

    Error Log:
    –2018-03-18 20:12:21-- http://192.168XXXXX//fog//management/export.php?type=sql
    Connecting to 192.168.XXXX:80… connected.
    HTTP request sent, awaiting response… 500 Internal Server Error
    2018-03-18 20:12:21 ERROR 500: Internal Server Error.

    Is authentication now required? Perhaps as part of the wget call in the script?

    Thanks


  • Senior Developer

    I was able to confirm and fix the issue.

    You will need to install working-1.5.1 to get the changes of course.

    Thanks for reporting.



  • Hi Tom, yes, sorry. I don’t know what happened with this post. I created it and I thought I posted it but when I looked back it was unavailable. Not sure what happened. Again sorry for wasting your time but yes, I still have an issue with the FOGBackup.sh program so please re-enable it.

    Thanks


  • Senior Developer

    Did you intend to push this as a bug or to remove it? If it’s to be removed let us know and we can purge it, if you meant to post it we can re-enable this.


 

487
Online

41.8k
Users

12.3k
Topics

116.1k
Posts