Fog install RHEL 7



  • Hi Everyone,

    I am new to using FOG and I wanted to try this out.
    I recently created a VM using RHEL 7 and tried to install fog on it. I have hit a minor impass where fog would try to restart the web service and it would fail at that portion.

    Is there an article somewhere that could help me with this issue?



  • @wayne-workman Thanks alot guys that fix the issue, now I just have this issue when opening the fog via the webpage I see that no storage is attached.

    0_1521139121302_Fog Image.PNG



  • @tom-elliott I’ve installed epel on RHEL 7 before. You need to use the CentOS 7 version of epel for RHEL 7. Although I have been meaning to tell you for a while now (10 months maybe?) that RHEL has a repository available called optional packages that is basically the same thing that epel is. I can get the exact details if needed, but it’s optional packages something something that is disabled by default inside of /etc/yum.repos.d/something (sorry, lots of fuzzy memories). It just needs enabled=false set to enabled=true. I say this because it’s probably better to use Red Hat provided optional packages over EPEL packages because Red Hat ensures they work with RHEL. However - epel works just fine and dandy for RHEL as well.


  • Senior Developer

    I could be wrong but epel is a fedora/centos thing, not a redhat (native) thing.

    You could try this:
    https://access.redhat.com/discussions/3140721

    Particularly (or as root):

    sudo rpm -ivh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
    sudo yum update
    


  • @wayne-workman [root@localhost carlisleadmin]# yum -y install epel-release
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
    : manager
    No package epel-release available.
    Error: Nothing to do



  • @israel-rodriquez What was the error when you manually tried?



  • @wayne-workman I just did and no luck.

    Would you like me to update this with the new log?



  • @israel-rodriquez Please try those steps to manually install EPEL, see how that goes.



  • @wayne-workman

    Hi Wayne,

    This is the official RHEL iso.



  • @israel-rodriquez Was this rhel 7 box installed from official RHEL ISO, or is this a customized server build?

    You may try installing epel beforehand manually like this:
    https://www.cyberciti.biz/faq/installing-rhel-epel-repo-on-centos-redhat-7-x/



  • Yes, I am connected to the internet.



  • @israel-rodriquez said in Fog install RHEL 7:

    No package epel-release available.

    That’s your problem. Does this box have internet access?



  • /bin/lsb_release
    /bin/systemctl
    package epel-release is not installed
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    No package epel-release available.
    Error: Nothing to do
    package remi-release-7 is not installed
    error: Failed dependencies:
    	epel-release = 7 is needed by remi-release-7.4-1.el7.remi.noarch
    Retrieving http://rpms.remirepo.net/enterprise/remi-release-7.rpm
    Loaded plugins: langpacks, product-id
    Loaded plugins: langpacks, product-id
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    
    NetworkManager.x86_64                 1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-adsl.x86_64            1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-config-server.noarch   1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-glib.x86_64            1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-libnm.x86_64           1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-ppp.x86_64             1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-team.x86_64            1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-tui.x86_64             1:1.8.0-11.el7_4        rhel-7-server-rpms
    NetworkManager-wifi.x86_64            1:1.8.0-11.el7_4        rhel-7-server-rpms
    accountsservice.x86_64                0.6.45-3.el7_4.1        rhel-7-server-rpms
    accountsservice-libs.x86_64           0.6.45-3.el7_4.1        rhel-7-server-rpms
    at.x86_64                             3.1.13-22.el7_4.2       rhel-7-server-rpms
    augeas-libs.x86_64                    1.4.0-2.el7_4.2         rhel-7-server-rpms
    bash.x86_64                           4.2.46-29.el7_4         rhel-7-server-rpms
    bind-libs.x86_64                      32:9.9.4-51.el7_4.2     rhel-7-server-rpms
    bind-libs-lite.x86_64                 32:9.9.4-51.el7_4.2     rhel-7-server-rpms
    bind-license.noarch                   32:9.9.4-51.el7_4.2     rhel-7-server-rpms
    bind-utils.x86_64                     32:9.9.4-51.el7_4.2     rhel-7-server-rpms
    binutils.x86_64                       2.25.1-32.base.el7_4.2  rhel-7-server-rpms
    bluez.x86_64                          5.44-4.el7_4            rhel-7-server-rpms
    copy-jdk-configs.noarch               2.2-5.el7_4             rhel-7-server-rpms
    cpio.x86_64                           2.11-25.el7_4           rhel-7-server-rpms
    cryptsetup.x86_64                     1.7.4-3.el7_4.1         rhel-7-server-rpms
    cryptsetup-libs.x86_64                1.7.4-3.el7_4.1         rhel-7-server-rpms
    cryptsetup-python.x86_64              1.7.4-3.el7_4.1         rhel-7-server-rpms
    device-mapper-multipath.x86_64        0.4.9-111.el7_4.2       rhel-7-server-rpms
    device-mapper-multipath-libs.x86_64   0.4.9-111.el7_4.2       rhel-7-server-rpms
    device-mapper-persistent-data.x86_64  0.7.0-0.1.rc6.el7_4.1   rhel-7-server-rpms
    dhclient.x86_64                       12:4.2.5-58.el7_4.3     rhel-7-server-rpms
    dhcp-common.x86_64                    12:4.2.5-58.el7_4.3     rhel-7-server-rpms
    dhcp-libs.x86_64                      12:4.2.5-58.el7_4.3     rhel-7-server-rpms
    dleyna-server.x86_64                  0.5.0-2.el7_4           rhel-7-server-rpms
    dnsmasq.x86_64                        2.76-2.el7_4.2          rhel-7-server-rpms
    dracut.x86_64                         033-502.el7_4.1         rhel-7-server-rpms
    dracut-config-rescue.x86_64           033-502.el7_4.1         rhel-7-server-rpms
    dracut-network.x86_64                 033-502.el7_4.1         rhel-7-server-rpms
    emacs-filesystem.noarch               1:24.3-20.el7_4         rhel-7-server-rpms
    evince.x86_64                         3.22.1-5.2.el7_4        rhel-7-server-rpms
    evince-libs.x86_64                    3.22.1-5.2.el7_4        rhel-7-server-rpms
    evince-nautilus.x86_64                3.22.1-5.2.el7_4        rhel-7-server-rpms
    firefox.x86_64                        52.6.0-1.el7_4          rhel-7-server-rpms
    flatpak.x86_64                        0.8.7-3.el7_4           rhel-7-server-rpms
    flatpak-libs.x86_64                   0.8.7-3.el7_4           rhel-7-server-rpms
    gdb.x86_64                            7.6.1-100.el7_4.1       rhel-7-server-rpms
    gdm.x86_64                            1:3.22.3-13.el7_4       rhel-7-server-rpms
    ghostscript.x86_64                    9.07-28.el7_4.2         rhel-7-server-rpms
    ghostscript-cups.x86_64               9.07-28.el7_4.2         rhel-7-server-rpms
    graphite2.x86_64                      1.3.10-1.el7_3          rhel-7-server-rpms
    grub2.x86_64                          1:2.02-0.65.el7_4.2     rhel-7-server-rpms
    grub2-common.noarch                   1:2.02-0.65.el7_4.2     rhel-7-server-rpms
    grub2-pc.x86_64                       1:2.02-0.65.el7_4.2     rhel-7-server-rpms
    grub2-pc-modules.noarch               1:2.02-0.65.el7_4.2     rhel-7-server-rpms
    grub2-tools.x86_64                    1:2.02-0.65.el7_4.2     rhel-7-server-rpms
    grub2-tools-extra.x86_64              1:2.02-0.65.el7_4.2     rhel-7-server-rpms
    grub2-tools-minimal.x86_64            1:2.02-0.65.el7_4.2     rhel-7-server-rpms
    gtk-update-icon-cache.x86_64          3.22.10-5.el7_4         rhel-7-server-rpms
    gtk3.x86_64                           3.22.10-5.el7_4         rhel-7-server-rpms
    gtk3-immodule-xim.x86_64              3.22.10-5.el7_4         rhel-7-server-rpms
    initscripts.x86_64                    9.49.39-1.el7_4.1       rhel-7-server-rpms
    iptables.x86_64                       1.4.21-18.3.el7_4       rhel-7-server-rpms
    ipxe-roms-qemu.noarch                 20170123-1.git4e85b27.el7_4.1
                                                                  rhel-7-server-rpms
    iwl100-firmware.noarch                39.31.5.1-58.el7_4      rhel-7-server-rpms
    iwl1000-firmware.noarch               1:39.31.5.1-58.el7_4    rhel-7-server-rpms
    iwl105-firmware.noarch                18.168.6.1-58.el7_4     rhel-7-server-rpms
    iwl135-firmware.noarch                18.168.6.1-58.el7_4     rhel-7-server-rpms
    iwl2000-firmware.noarch               18.168.6.1-58.el7_4     rhel-7-server-rpms
    iwl2030-firmware.noarch               18.168.6.1-58.el7_4     rhel-7-server-rpms
    iwl3160-firmware.noarch               22.0.7.0-58.el7_4       rhel-7-server-rpms
    iwl3945-firmware.noarch               15.32.2.9-58.el7_4      rhel-7-server-rpms
    iwl4965-firmware.noarch               228.61.2.24-58.el7_4    rhel-7-server-rpms
    iwl5000-firmware.noarch               8.83.5.1_1-58.el7_4     rhel-7-server-rpms
    iwl5150-firmware.noarch               8.24.2.2-58.el7_4       rhel-7-server-rpms
    iwl6000-firmware.noarch               9.221.4.1-58.el7_4      rhel-7-server-rpms
    iwl6000g2a-firmware.noarch            17.168.5.3-58.el7_4     rhel-7-server-rpms
    iwl6000g2b-firmware.noarch            17.168.5.2-58.el7_4     rhel-7-server-rpms
    iwl6050-firmware.noarch               41.28.5.1-58.el7_4      rhel-7-server-rpms
    iwl7260-firmware.noarch               22.0.7.0-58.el7_4       rhel-7-server-rpms
    iwl7265-firmware.noarch               22.0.7.0-58.el7_4       rhel-7-server-rpms
    java-1.8.0-openjdk.x86_64             1:1.8.0.161-0.b14.el7_4 rhel-7-server-rpms
    java-1.8.0-openjdk-headless.x86_64    1:1.8.0.161-0.b14.el7_4 rhel-7-server-rpms
    kernel.x86_64                         3.10.0-693.21.1.el7     rhel-7-server-rpms
    kernel-tools.x86_64                   3.10.0-693.21.1.el7     rhel-7-server-rpms
    kernel-tools-libs.x86_64              3.10.0-693.21.1.el7     rhel-7-server-rpms
    kexec-tools.x86_64                    2.0.14-17.2.el7_4       rhel-7-server-rpms
    kmod.x86_64                           20-15.el7_4.7           rhel-7-server-rpms
    kmod-libs.x86_64                      20-15.el7_4.7           rhel-7-server-rpms
    kpartx.x86_64                         0.4.9-111.el7_4.2       rhel-7-server-rpms
    kpatch.noarch                         0.4.0-2.el7_4           rhel-7-server-rpms
    libblkid.x86_64                       2.23.2-43.el7_4.2       rhel-7-server-rpms
    libdb.x86_64                          5.3.21-21.el7_4         rhel-7-server-rpms
    libdb-utils.x86_64                    5.3.21-21.el7_4         rhel-7-server-rpms
    libgcab1.x86_64                       0.7-4.el7_4             rhel-7-server-rpms
    libgudev1.x86_64                      219-42.el7_4.10         rhel-7-server-rpms
    liblouis.x86_64                       2.5.2-12.el7_4          rhel-7-server-rpms
    liblouis-python.noarch                2.5.2-12.el7_4          rhel-7-server-rpms
    libmount.x86_64                       2.23.2-43.el7_4.2       rhel-7-server-rpms
    libpciaccess.x86_64                   0.13.4-3.1.el7_4        rhel-7-server-rpms
    libreswan.x86_64                      3.20-5.el7_4            rhel-7-server-rpms
    libsmbclient.x86_64                   4.6.2-12.el7_4          rhel-7-server-rpms
    libsoup.x86_64                        2.56.0-4.el7_4          rhel-7-server-rpms
    libsss_idmap.x86_64                   1.15.2-50.el7_4.11      rhel-7-server-rpms
    libsss_nss_idmap.x86_64               1.15.2-50.el7_4.11      rhel-7-server-rpms
    libstoragemgmt.x86_64                 1.4.0-5.el7_4           rhel-7-server-rpms
    libstoragemgmt-python.noarch          1.4.0-5.el7_4           rhel-7-server-rpms
    libstoragemgmt-python-clibs.x86_64    1.4.0-5.el7_4           rhel-7-server-rpms
    libteam.x86_64                        1.25-6.el7_4.3          rhel-7-server-rpms
    libtevent.x86_64                      0.9.31-2.el7_4          rhel-7-server-rpms
    libuuid.x86_64                        2.23.2-43.el7_4.2       rhel-7-server-rpms
    libvirt-daemon.x86_64                 3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-config-network.x86_64  3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-interface.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-network.x86_64  3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-nodedev.x86_64  3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-nwfilter.x86_64 3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-qemu.x86_64     3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-secret.x86_64   3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage.x86_64  3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-core.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-disk.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-gluster.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-iscsi.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-logical.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-mpath.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-rbd.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-driver-storage-scsi.x86_64
                                          3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-daemon-kvm.x86_64             3.2.0-14.el7_4.9        rhel-7-server-rpms
    libvirt-libs.x86_64                   3.2.0-14.el7_4.9        rhel-7-server-rpms
    libwbclient.x86_64                    4.6.2-12.el7_4          rhel-7-server-rpms
    linux-firmware.noarch                 20170606-58.gitc990aae.el7_4
                                                                  rhel-7-server-rpms
    microcode_ctl.x86_64                  2:2.1-22.5.el7_4        rhel-7-server-rpms
    mutter.x86_64                         3.22.3-12.el7_4         rhel-7-server-rpms
    nautilus.x86_64                       3.22.3-4.el7_4          rhel-7-server-rpms
    nautilus-extensions.x86_64            3.22.3-4.el7_4          rhel-7-server-rpms
    ncurses.x86_64                        5.9-14.20130511.el7_4   rhel-7-server-rpms
    ncurses-base.noarch                   5.9-14.20130511.el7_4   rhel-7-server-rpms
    ncurses-libs.x86_64                   5.9-14.20130511.el7_4   rhel-7-server-rpms
    net-snmp-libs.x86_64                  1:5.7.2-28.el7_4.1      rhel-7-server-rpms
    nss.x86_64                            3.28.4-15.el7_4         rhel-7-server-rpms
    nss-softokn.x86_64                    3.28.3-8.el7_4          rhel-7-server-rpms
    nss-softokn-freebl.x86_64             3.28.3-8.el7_4          rhel-7-server-rpms
    nss-sysinit.x86_64                    3.28.4-15.el7_4         rhel-7-server-rpms
    nss-tools.x86_64                      3.28.4-15.el7_4         rhel-7-server-rpms
    openssh.x86_64                        7.4p1-13.el7_4          rhel-7-server-rpms
    openssh-clients.x86_64                7.4p1-13.el7_4          rhel-7-server-rpms
    openssh-server.x86_64                 7.4p1-13.el7_4          rhel-7-server-rpms
    poppler.x86_64                        0.26.5-17.el7_4         rhel-7-server-rpms
    poppler-glib.x86_64                   0.26.5-17.el7_4         rhel-7-server-rpms
    poppler-utils.x86_64                  0.26.5-17.el7_4         rhel-7-server-rpms
    python-dmidecode.x86_64               3.12.2-1.1.el7          rhel-7-server-rpms
    python-gobject.x86_64                 3.22.0-1.el7_4.1        rhel-7-server-rpms
    python-gobject-base.x86_64            3.22.0-1.el7_4.1        rhel-7-server-rpms
    python-perf.x86_64                    3.10.0-693.21.1.el7     rhel-7-server-rpms
    python-rhsm.x86_64                    1.19.10-1.el7_4         rhel-7-server-rpms
    python-rhsm-certificates.x86_64       1.19.10-1.el7_4         rhel-7-server-rpms
    qemu-img.x86_64                       10:1.5.3-141.el7_4.6    rhel-7-server-rpms
    qemu-kvm.x86_64                       10:1.5.3-141.el7_4.6    rhel-7-server-rpms
    qemu-kvm-common.x86_64                10:1.5.3-141.el7_4.6    rhel-7-server-rpms
    rhnsd.x86_64                          5.0.13-7.3.el7_4        rhel-7-server-rpms
    samba-client-libs.x86_64              4.6.2-12.el7_4          rhel-7-server-rpms
    samba-common.noarch                   4.6.2-12.el7_4          rhel-7-server-rpms
    scl-utils.x86_64                      20130529-18.el7_4       rhel-7-server-rpms
    seabios-bin.noarch                    1.10.2-3.el7_4.1        rhel-7-server-rpms
    seavgabios-bin.noarch                 1.10.2-3.el7_4.1        rhel-7-server-rpms
    selinux-policy.noarch                 3.13.1-166.el7_4.9      rhel-7-server-rpms
    selinux-policy-targeted.noarch        3.13.1-166.el7_4.9      rhel-7-server-rpms
    sos.noarch                            3.4-13.el7_4            rhel-7-server-rpms
    spice-glib.x86_64                     0.33-6.el7_4.1          rhel-7-server-rpms
    spice-gtk3.x86_64                     0.33-6.el7_4.1          rhel-7-server-rpms
    spice-server.x86_64                   0.12.8-2.el7.1          rhel-7-server-rpms
    sssd-client.x86_64                    1.15.2-50.el7_4.11      rhel-7-server-rpms
    subscription-manager.x86_64           1.19.23-1.el7_4         rhel-7-server-rpms
    subscription-manager-gui.x86_64       1.19.23-1.el7_4         rhel-7-server-rpms
    subscription-manager-initial-setup-addon.x86_64
                                          1.19.23-1.el7_4         rhel-7-server-rpms
    sudo.x86_64                           1.8.19p2-11.el7_4       rhel-7-server-rpms
    systemd.x86_64                        219-42.el7_4.10         rhel-7-server-rpms
    systemd-libs.x86_64                   219-42.el7_4.10         rhel-7-server-rpms
    systemd-python.x86_64                 219-42.el7_4.10         rhel-7-server-rpms
    systemd-sysv.x86_64                   219-42.el7_4.10         rhel-7-server-rpms
    systemtap-runtime.x86_64              3.1-5.el7_4             rhel-7-server-rpms
    teamd.x86_64                          1.25-6.el7_4.3          rhel-7-server-rpms
    tigervnc-license.noarch               1.8.0-2.el7_4           rhel-7-server-rpms
    tigervnc-server-minimal.x86_64        1.8.0-2.el7_4           rhel-7-server-rpms
    tuned.noarch                          2.8.0-5.el7_4.2         rhel-7-server-rpms
    tzdata.noarch                         2018c-1.el7             rhel-7-server-rpms
    tzdata-java.noarch                    2018c-1.el7             rhel-7-server-rpms
    util-linux.x86_64                     2.23.2-43.el7_4.2       rhel-7-server-rpms
    webkitgtk4.x86_64                     2.14.7-3.el7            rhel-7-server-rpms
    webkitgtk4-jsc.x86_64                 2.14.7-3.el7            rhel-7-server-rpms
    webkitgtk4-plugin-process-gtk2.x86_64 2.14.7-3.el7            rhel-7-server-rpms
    wpa_supplicant.x86_64                 1:2.6-5.el7_4.1         rhel-7-server-rpms
    xmlsec1.x86_64                        1.2.20-7.el7_4          rhel-7-server-rpms
    xmlsec1-openssl.x86_64                1.2.20-7.el7_4          rhel-7-server-rpms
    xorg-x11-server-Xorg.x86_64           1.19.3-11.el7_4.2       rhel-7-server-rpms
    xorg-x11-server-common.x86_64         1.19.3-11.el7_4.2       rhel-7-server-rpms
    Obsoleting Packages
    grub2.x86_64                          1:2.02-0.65.el7_4.2     rhel-7-server-rpms
        grub2.x86_64                      1:2.02-0.64.el7         @anaconda/7.4     
    grub2-tools.x86_64                    1:2.02-0.65.el7_4.2     rhel-7-server-rpms
        grub2-tools.x86_64                1:2.02-0.64.el7         @anaconda/7.4     
    grub2-tools-extra.x86_64              1:2.02-0.65.el7_4.2     rhel-7-server-rpms
        grub2-tools.x86_64                1:2.02-0.64.el7         @anaconda/7.4     
    grub2-tools-minimal.x86_64            1:2.02-0.65.el7_4.2     rhel-7-server-rpms
        grub2-tools.x86_64                1:2.02-0.64.el7         @anaconda/7.4     
    bc-1.06.95-13.el7.x86_64
    curl-7.29.0-42.el7_4.1.x86_64
    gcc-4.8.5-16.el7_4.2.x86_64
    gcc-c++-4.8.5-16.el7_4.2.x86_64
    genisoimage-1.1.11-23.el7.x86_64
    gzip-1.5-9.el7.x86_64
    httpd-2.4.6-67.el7_4.6.x86_64
    lftp-4.4.8-8.el7_3.2.x86_64
    m4-1.4.16-10.el7.x86_64
    make-3.82-23.el7.x86_64
    mod_ssl-2.4.6-67.el7_4.6.x86_64
    mtools-4.0.18-5.el7.x86_64
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Error: No matching Packages to list
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Installed Packages
    mariadb.x86_64                1:5.5.56-2.el7                 @rhel-7-server-rpms
    mariadb-5.5.56-2.el7.x86_64
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Error: No matching Packages to list
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Installed Packages
    mariadb-server.x86_64             1:5.5.56-2.el7             @rhel-7-server-rpms
    mariadb-server-5.5.56-2.el7.x86_64
    net-tools-2.0-0.22.20131004git.el7.x86_64
    nfs-utils-1.3.0-0.48.el7_4.2.x86_64
    php-5.4.16-43.el7_4.1.x86_64
    package php-bcmath is not installed
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Error: No matching Packages to list
    php-cli-5.4.16-43.el7_4.1.x86_64
    php-common-5.4.16-43.el7_4.1.x86_64
    package php-fpm is not installed
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Error: No matching Packages to list
    php-gd-5.4.16-43.el7_4.1.x86_64
    php-ldap-5.4.16-43.el7_4.1.x86_64
    package php-mbstring is not installed
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Error: No matching Packages to list
    package php-mcrypt is not installed
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Error: No matching Packages to list
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Error: No matching Packages to list
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    Installed Packages
    php-mysql.x86_64              5.4.16-43.el7_4.1              @rhel-7-server-rpms
    php-mysql-5.4.16-43.el7_4.1.x86_64
    php-process-5.4.16-43.el7_4.1.x86_64
    syslinux-4.05-13.el7.x86_64
    tar-1.26-32.el7.x86_64
    tftp-server-5.2-13.el7.x86_64
    unzip-6.0-16.el7.x86_64
    vsftpd-3.0.2-22.el7.x86_64
    wget-1.14-15.el7_4.1.x86_64
    xinetd-2.3.15-13.el7.x86_64
    xz-devel-5.2.2-1.el7.x86_64
    Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
                  : manager
    No packages marked for update
    bc-1.06.95-13.el7.x86_64
    curl-7.29.0-42.el7_4.1.x86_64
    gcc-4.8.5-16.el7_4.2.x86_64
    gcc-c++-4.8.5-16.el7_4.2.x86_64
    genisoimage-1.1.11-23.el7.x86_64
    gzip-1.5-9.el7.x86_64
    httpd-2.4.6-67.el7_4.6.x86_64
    lftp-4.4.8-8.el7_3.2.x86_64
    m4-1.4.16-10.el7.x86_64
    make-3.82-23.el7.x86_64
    mariadb-5.5.56-2.el7.x86_64
    mariadb-server-5.5.56-2.el7.x86_64
    mod_ssl-2.4.6-67.el7_4.6.x86_64
    mtools-4.0.18-5.el7.x86_64
    net-tools-2.0-0.22.20131004git.el7.x86_64
    nfs-utils-1.3.0-0.48.el7_4.2.x86_64
    php-5.4.16-43.el7_4.1.x86_64
    php-cli-5.4.16-43.el7_4.1.x86_64
    php-common-5.4.16-43.el7_4.1.x86_64
    php-gd-5.4.16-43.el7_4.1.x86_64
    php-ldap-5.4.16-43.el7_4.1.x86_64
    php-mysql-5.4.16-43.el7_4.1.x86_64
    php-process-5.4.16-43.el7_4.1.x86_64
    syslinux-4.05-13.el7.x86_64
    tar-1.26-32.el7.x86_64
    tftp-server-5.2-13.el7.x86_64
    unzip-6.0-16.el7.x86_64
    vsftpd-3.0.2-22.el7.x86_64
    wget-1.14-15.el7_4.1.x86_64
    xinetd-2.3.15-13.el7.x86_64
    xz-devel-5.2.2-1.el7.x86_64
    New password: Retype new password: Changing password for user fog.
    passwd: all authentication tokens updated successfully.
    Failed to stop FOGMulticastManager.service: Unit FOGMulticastManager.service not loaded.
    Failed to stop FOGImageReplicator.service: Unit FOGImageReplicator.service not loaded.
    Failed to stop FOGSnapinReplicator.service: Unit FOGSnapinReplicator.service not loaded.
    Failed to stop FOGScheduler.service: Unit FOGScheduler.service not loaded.
    Failed to stop FOGPingHosts.service: Unit FOGPingHosts.service not loaded.
    Failed to stop FOGSnapinHash.service: Unit FOGSnapinHash.service not loaded.
    Failed to stop FOGImageSize.service: Unit FOGImageSize.service not loaded.
    Failed to execute operation: Invalid argument
    ● mariadb.service - MariaDB database server
       Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2018-03-14 16:05:25 EDT; 2s ago
      Process: 18649 ExecStartPost=/usr/libexec/mariadb-wait-ready $MAINPID (code=exited, status=0/SUCCESS)
      Process: 18613 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=0/SUCCESS)
     Main PID: 18648 (mysqld_safe)
       CGroup: /system.slice/mariadb.service
               ├─18648 /bin/sh /usr/bin/mysqld_safe --basedir=/usr
               └─18810 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --log-error=/var/log/mariadb/mariadb.log --pid-file=/var/run/mariadb/mariadb.pid --socket=/var/lib/mysql/mysql.sock
    
    Mar 14 16:05:23 localhost.localdomain systemd[1]: Starting MariaDB database server...
    Mar 14 16:05:23 localhost.localdomain mariadb-prepare-db-dir[18613]: Database MariaDB is probably initialized in /var/lib/mysql already, nothing is done.
    Mar 14 16:05:23 localhost.localdomain mariadb-prepare-db-dir[18613]: If this is not the case, make sure the /var/lib/mysql is empty before running mariadb-prepare-db-dir.
    Mar 14 16:05:23 localhost.localdomain mysqld_safe[18648]: 180314 16:05:23 mysqld_safe Logging to '/var/log/mariadb/mariadb.log'.
    Mar 14 16:05:23 localhost.localdomain mysqld_safe[18648]: 180314 16:05:23 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    Mar 14 16:05:25 localhost.localdomain systemd[1]: Started MariaDB database server.
    Failed to stop php-fpm.service: Unit php-fpm.service not loaded.
    


  • Tried what was on the document and no luck.

    Attached is the logs
    [0_1521058012755_fog_error_1.5.0.log](Uploading 100%)


  • Senior Developer


 

332
Online

41.2k
Users

11.6k
Topics

110.7k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.