Power Management Tasks



  • Running Version 69
    SVN Revision: 6079
    Client = 11.12

    I have setup a cron job to shutdown a machine as a specific time.
    I was playing with cron jobs for groups for WOL and am happy i have the setting correct. Anyway, Windows doesn’t shutdown.

    Power Management is ticked on the host and the log =

    --------------------------------------------------------------------------
    ------------------------------PowerManagement-----------------------------
    --------------------------------------------------------------------------
     08/03/2018 19:07 Client-Info Client Version: 0.11.12
     08/03/2018 19:07 Client-Info Client OS:      Windows
     08/03/2018 19:07 Client-Info Server Version: 69
     08/03/2018 19:07 Middleware::Response Success
     08/03/2018 19:07 PowerManagement Calculating tasks to unschedule
     08/03/2018 19:07 PowerManagement Calculating tasks to schedule
    --------------------------------------------------------------------------
    

    any advise?

    <Sorry, also is there a way to have the CRON jobs added by default to new hosts?>


  • Senior Developer

    @itcc correct



  • i’ve got to version 1.5.0.16

    using: git checkout working-1.5.1

    that right?



  • @tom-elliott

    sorry didn’t see the branch in the message.



  • @tom-elliott
    is that back on the Dev-branch?


  • Senior Developer

    @itcc I don’t know what’s going on with groups sorry for that but the git branch working-1.5.1 has the fix for power management deletion from groups



  • So i have done the upgrade and i created a test group and push some settings.
    That worked well, thanks …but in the group when i press delete all PM tasks it doesn’t take effect.

    Also, When i search for the hosts of this group random machines are also listed. The group also has more than i added listed.

    I have run the database maintenance tasks but it’s the same.
    do you have an SQL query to delete all PMs from all devices?

    and/or any ideas on whats up with the groups and not deleting PMs

    Thanks



  • @itcc This version you’re on is from July. Please update to the latest release, currently FOG 1.5.0. Instructions are below. You will most likely need to switch your repository to the master branch. https://wiki.fogproject.org/wiki/index.php?title=Getting_FOG



  • Any ideas?



  • f48a98bd6ee3b4f8c5bc9256e0087b97946b53df



  • @itcc said in Power Management Tasks:

    Looked and can’t find another version number

    If you go into your git directory (the one created by cloning fogproject), you can run this command to get the commit hash:
    git log -1 --format="%H"
    It’s really important for us to know exactly what version you are on.



    • Looked and can’t find another version number
    • Confirm correct time Server
    • Confirm correct time Host
      0_1520546753272_2759c1cf-de7b-4250-8f44-b8644398050e-image.png

    Please note that when i came in to screenshot the red ring was set to ‘Select cron job’ I have changed this to weekly and am testing now.

    This was set from the group. I checked by adding another and selecting the schedule in the group view doesn’t get set in the host. would/could this be the issue?



  • @itcc Four questions:

    • Exact fog version please.
    • Is your server time correct?
    • Is the host’s time correct?
    • Can you show us what you’re putting into power management via screenshot please?

 

416
Online

41.6k
Users

12.1k
Topics

114.4k
Posts