Cannot Deploy Images. Require Assistance ASAP!



  • Hi All…

    I work in the IT department for a special needs school in the UK.
    We’ve been using Fog for a long time but due to an error we were forced to rebuild our Fog server.
    We are now using version 0.32 but are having problems.

    When trying to deploy an image it displays this message:
    [INDENT=1] Loading fog/kernel/bzImage …[/INDENT]
    [INDENT=1]Loading /fog/images/init.gz … ready[/INDENT]
    [INDENT=1]tps65010: no chip?[/INDENT]
    [INDENT=1]acpiphp_ibm: ibm_acpiphp_init: acpi_walk_namespace failed[/INDENT]
    [INDENT=1]Cound not find Carillo Ranch MCH device.[/INDENT]
    [INDENT=1]uvesafb: failed to execute /sbin/v86d[/INDENT]
    [INDENT=1]uvesafb: make sure that the v86d helper is installed and executable[/INDENT]
    [INDENT=1]uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)[/INDENT]
    [INDENT=1]uevesafb: vbe_init() failed with -22[/INDENT]
    [INDENT=1]drm/i810 does not support smp[/INDENT]
    [INDENT=1]Error: Driver “mdio-gpio” is already registered, aborting…[/INDENT]
    [INDENT=1]cs89x0: request_region(0x320, 0x10) failed[/INDENT]
    [INDENT=1]LocalTalk card not found; 220 = ff, 240 = ff.[/INDENT]
    [INDENT=1]winstron_btns: System Unknown[/INDENT]
    [INDENT=1]Acer_wmi: No or unsupported WMI interface, unabel to load[/INDENT]
    [INDENT=1]acerhdf: unknown (unsuppored) BIOS version Hewlett Packard/HP Pro 3300 Series SFF/7.14, please report, aborting![/INDENT]
    [INDENT=1]Initializing random number generator… done![/INDENT]
    [INDENT=1]Starting Network…[/INDENT]
    [INDENT=1]IP: RTNETLINK answers: File Exists[/INDENT]

    It does this (or similar) on any PC I try and deploy. The PC I am trying to deply to is a HP Pro 3300 SFF which is fairly new, although I did manage to deploy one on our older version of FOG.
    I have also tried this on a much older Dell Optiplex GX280 which has been fogged up and down many times in the past with the old version.

    After it displays the error message it states it is checking the queue, says done and then proceeds to fill the screen with what appears to be a timer.
    Example:
    (5 Sec)
    (15 Sec)…
    This just continues endlessly.

    We have tried following the steps documented in the "Troubleshooting and Image Deploy - Wiki"
    This has enabled us to deploy an image to a HP 3300 this way but it still won’t work from the Web GUI.

    Please can someone assist ASAP as I need to get the computers installed ideally by yesterday!

    Many Thanks In Advance!
    [INDENT=1] [/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1] [/INDENT]


  • Moderator

    Ajay, please start a new thread and give as much information as possible. If you would like, reference this thread if it contains relevant information.

    Generally, we need to know what version of FOG on what OS. Is it a (N)ormal server or a (S)torage node?



  • Same problem I faced right now. But in my case I came up with fresh installation.
    I tried " [url]http://192.168.1.100:81/fog/service/Pre_Stage1.php?mac=00:13:a9:f3:3b:2a[/url]" and result is
    [SIZE=4][FONT=Times New Roman][COLOR=#000000]" ##@GO "[/COLOR][/FONT][/SIZE]

    [SIZE=4][FONT=Times New Roman][COLOR=#000000]Any Idea??[/COLOR][/FONT][/SIZE]


  • Moderator

    When this is happening, open a browser and go to: [I][url]http://[fog-server]/service/Pre_Stage1.php?mac=[mac-of-client-you’re-trying-to-deploy][/url][/I] to see what you get.

    Replace [fog-server] with the name or IP address of your FOG server, and [mac-of-client…] with the mac address of the client, numbers only, no : or -, like 000c12345678.

    You can get this info from the task file in /tftpboot/pxelinux.cfg/01-[mac address]. If you open the file you can see the mac argument passed to fog and copy it from there.



  • Hi Chad

    I had tried a few different Kernel’s but I hadn’t tried that yet.
    Just done so and now I don’t get all the error messages I just still have the issue where it says

    Checking Queue… Done

    • (0 sec)
    • (5 sec)
    • (10 sec)

  • Moderator

    Go back to the kernel that you used with the version of FOG on your previous install. You might try the kernel from 0.29 if you can’t remember.


Log in to reply
 

433
Online

38998
Users

10717
Topics

101752
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.