Super simple unattend/customize.xml for Windows 10 1709



  • I have successfully created and deployed a sysprepped image of Win 10 1709 without using a unattend.xml file. However, I would really like to skip the loud Cortana OOBE and set a few standard settings like language and timezone.

    So far, every file I try to apply (via sysprep /generalize /shutdown /unattend:C:\Windows\Customize\customize.xml) results in the standard ‘Windows is unable to complete setup on this computer’ error and the errors I have looked at in the logs don’t seem particularly helpful. FYI, I have used the xml generator here http://windowsafg.no-ip.org/win10x86_x64_uefi.html to generate the files and have run them through the MS WSIM and nothing looks out of the ordinary.

    Does anyone have a vanilla .xml that works and doesn’t bomb in Win10 1709?

    Thanks everyone,
    Leigh Johnson



  • @itcc I do – please send me yours. I’ve done million tests, I’ve had MS case open (we have EA with unlimited cases but you get what you pay for - shit) and the issue with windows.immersivecontrolpanel is plaguing us. If you don’t know about this in 1709 it has to do with search not working and from there IE and ton of other crap. The lousy fix is to copy windows.immersivecontrolpanel to each future user c:\users\xxx profile. As I said a lousy fix.

    If anyone can share their working xml that would be awesome!

    alt text



  • @itcc I aplologize for the sporadic updates, but I have a million things on my plate and this is lower down the priority list.

    So far I have yet to make any .xml file work, even using George’s suggestions and his example file.

    At the moment, we’re living with the OOBE process, but it would really streamline things if I could skip it.

    I’ll be happy to test with your file if you’ll send it over…

    Thanks,
    Leigh



  • Do you still need one?
    I can send you mine.



  • @sebastian-roth Not yet; I am in the process on testing right now. If everything cooperates, I’ll marked as solved.


  • Developer

    @LJohnsonTX Is this solved then?



  • Thanks George!


  • Moderator

    As for the chatty cortana, this article will give you a quiet deployment. https://community.spiceworks.com/topic/2100746-cortana-talks-to-me-durring-sccm-task-sequence

    Follow my guidance on the naming and location of your unattend.xml file.

    Here is my sysprep command. I have it in a batch file that is placed on the reference image during MDT reference image build.
    c:\windows\system32\sysprep\sysprep.exe /quiet /generalize /oobe /shutdown /unattend:C:\Windows\Panther\Unattend.xml

    The timezone and language are set in your unattend.xml file. That works well.

    Understand that the unattend.xml file and setupcomplete.cmd files will only run if you have VLK media. If you are trying to customize Win10 OEM media deployment you will have a difficult time.

    Also, look at your chat icon in the FOG Forums, I have some additional information there.


  • Moderator

    I don’t have time at the moment for a complete response, but there are a few things you need to fix. Starting with the no-ip.org unattend.xml is a really good choice. But your file should be called unattend.xml and it shall be placed in C:\Window\Panther.

    Somewhere I have the fix for cortana during oobe. It scared the hell out of me every time I images until I muted her.

    If you are using FOG for imaging you will want to remove the disk commands from your unattend.xml file.



  • @ljohnsontx

    If it helps, here is the original customize.xml I attempted:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SetupUILanguage>
    <UILanguage>en-US</UILanguage>
    </SetupUILanguage>
    <InputLocale>0409:00000409</InputLocale>
    <SystemLocale>en-US</SystemLocale>
    <UILanguage>en-US</UILanguage>
    <UILanguageFallback>en-US</UILanguageFallback>
    <UserLocale>en-US</UserLocale>
    </component>
    <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <DiskConfiguration>
    <Disk wcm:action="add">
    <DiskID>0</DiskID>
    <WillWipeDisk>true</WillWipeDisk>
    <CreatePartitions>
    <!-- Windows RE Tools partition -->
    <CreatePartition wcm:action="add">
    <Order>1</Order>
    <Type>Primary</Type>
    <Size>300</Size>
    </CreatePartition>
    <!-- System partition (ESP) -->
    <CreatePartition wcm:action="add">
    <Order>2</Order>
    <Type>EFI</Type>
    <Size>100</Size>
    </CreatePartition>
    <!-- Microsoft reserved partition (MSR) -->
    <CreatePartition wcm:action="add">
    <Order>3</Order>
    <Type>MSR</Type>
    <Size>128</Size>
    </CreatePartition>
    <!-- Windows partition -->
    <CreatePartition wcm:action="add">
    <Order>4</Order>
    <Type>Primary</Type>
    <Extend>true</Extend>
    </CreatePartition>
    </CreatePartitions>
    <ModifyPartitions>
    <!-- Windows RE Tools partition -->
    <ModifyPartition wcm:action="add">
    <Order>1</Order>
    <PartitionID>1</PartitionID>
    <Label>WINRE</Label>
    <Format>NTFS</Format>
    </ModifyPartition>
    <!-- System partition (ESP) -->
    <ModifyPartition wcm:action="add">
    <Order>2</Order>
    <PartitionID>2</PartitionID>
    <Label>System</Label>
    <Format>FAT32</Format>
    </ModifyPartition>
    <!-- MSR partition does not need to be modified -->
    <ModifyPartition wcm:action="add">
    <Order>3</Order>
    <PartitionID>3</PartitionID>
    </ModifyPartition>
    <!-- Windows partition -->
    <ModifyPartition wcm:action="add">
    <Order>4</Order>
    <PartitionID>4</PartitionID>
    <Label>OS</Label>
    <Letter>C</Letter>
    <Format>NTFS</Format>
    </ModifyPartition>
    </ModifyPartitions>
    </Disk>
    </DiskConfiguration>
    <ImageInstall>
    <OSImage>
    <InstallTo>
    <DiskID>0</DiskID>
    <PartitionID>4</PartitionID>
    </InstallTo>
    <InstallToAvailablePartition>false</InstallToAvailablePartition>
    </OSImage>
    </ImageInstall>
    <UserData>
    <ProductKey>
    <Key></Key>
    <WillShowUI>Never</WillShowUI>
    </ProductKey>
    <AcceptEula>true</AcceptEula>
    <FullName>FullName</FullName>
    <Organization>Organization</Organization>
    </UserData>
    </component>
    </settings>
    <settings pass="offlineServicing">
    <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <EnableLUA>true</EnableLUA>
    </component>
    </settings>
    <settings pass="generalize">
    <component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SkipRearm>1</SkipRearm>
    </component>
    </settings>
    <settings pass="specialize">
    <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <InputLocale>0409:00000409</InputLocale>
    <SystemLocale>en-US</SystemLocale>
    <UILanguage>en-US</UILanguage>
    <UILanguageFallback>en-US</UILanguageFallback>
    <UserLocale>en-US</UserLocale>
    </component>
    <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SkipAutoActivation>true</SkipAutoActivation>
    </component>
    <component name="Microsoft-Windows-SQMApi" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <CEIPEnabled>1</CEIPEnabled>
    </component>
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <ComputerName>TOP-NEW-PC</ComputerName>
    </component>
    </settings>
    <settings pass="oobeSystem">
    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <AutoLogon>
    <Password>
    <Value>thisisnotreallymypassword</Value>
    <PlainText>true</PlainText>
    </Password>
    <Enabled>true</Enabled>
    <Username>LocalAccount</Username>
    </AutoLogon>
    <OOBE>
    <HideEULAPage>true</HideEULAPage>
    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
    <NetworkLocation>Work</NetworkLocation>
    <SkipUserOOBE>true</SkipUserOOBE>
    <SkipMachineOOBE>true</SkipMachineOOBE>
    <ProtectYourPC>1</ProtectYourPC>
    </OOBE>
    <UserAccounts>
    <LocalAccounts>
    <LocalAccount wcm:action="add">
    <Password>
    <Value>thisisnotreallymypassword</Value>
    <PlainText>true</PlainText>
    </Password>
    <Description>Local Admin</Description>
    <DisplayName>Local Admin Account</DisplayName>
    <Group>Administrators</Group>
    <Name>LocalAccount</Name>
    </LocalAccount>
    </LocalAccounts>
    </UserAccounts>
    <RegisteredOrganization>Organizationr</RegisteredOrganization>
    <RegisteredOwner>Owner</RegisteredOwner>
    <DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
    <FirstLogonCommands>
    <SynchronousCommand wcm:action="add">
    <Description>Control Panel View</Description>
    <Order>1</Order>
    <CommandLine>reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel" /v StartupPage /t REG_DWORD /d 0 /f</CommandLine>
    <RequiresUserInput>true</RequiresUserInput>
    </SynchronousCommand>
    <SynchronousCommand wcm:action="add">
    <Order>2</Order>
    <Description>Control Panel Icon Size</Description>
    <RequiresUserInput>false</RequiresUserInput>
    <CommandLine>reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel" /v AllItemsIconView /t REG_DWORD /d 0 /f</CommandLine>
    </SynchronousCommand>
    <SynchronousCommand wcm:action="add">
    <Description>SetupComplete</Description>
    <Order>3</Order>
    <CommandLine>C:\Windows\Setup\Scripts\SetupComplete.cmd</CommandLine>
    <RequiresUserInput>false</RequiresUserInput>
    </SynchronousCommand>
    </FirstLogonCommands>
    </component>
    </settings>
    </unattend>```

 

444
Online

41.9k
Users

12.5k
Topics

117.6k
Posts