Problem Register host quick and full



  • Hi,

    I am trying to register a host that has this motherboard asrock n68-s3 fx and it is returning me the error below, anything I do in fog it arrives in that same error

    0_1519393411526_IMG_20180223_101542038_HDR.jpg

    https://imgur.com/wLnos4w

    help guys

    thank


  • Developer

    @zago123 What exactly did you change. Other users might come across this and hope to find your answer.



  • @george1421
    I will check my structure again, but it was solved, the cause was the pci express on the motherboard, I changed and now it boot normally

    thanks for the help guys


  • Moderator

    @zago123 Understand I can only guess at the cause because I don’t know your network. But again this makes me think its because you have spanning tree enabled on your network switch and you are not using one of the fast spanning tree protocols.

    I can explain it this way. When you turn your target computer on, the link light goes on (or may already be on if you have vpro installed). So your computer pxe boots and loads the iPXE kernel from the FOG server. When iPXE kernel starts, it will momentarily turn off the link light and then back on as iPXE now manages the network adapter. This is all normal. The problem is if standard spanning tree is enabled, when iPXE turns off the link light, spanning tree stops the network port from forwarding data for 27 seconds to see if it hears a BPDU packet (i.e. someone plugged another switch into the port. The building switch doesn’t know so it listens before forwarding. This is standard spanning tree design). Well for FOG 27 seconds is a long time and FOG has already given up on booting by the time spanning tree starts forwarding data.

    The no configuration methods error means that iPXE could not get a dhcp address from your dhcp server and timed out. If you were to hit the s key at that message to get the iPXE shell, then wait 30 seconds and key in dhcp net0 my idea is that iPXE will pick up an IP address. If it does then it is for sure a spanning tree issue.

    Again this is not specifically a fog problem, but a problem with your networking infrastructure. We are here to help you, but we can only do so much since you have not started FOG yet.



  • @george1421 hey guys, i solved here, problem in pci express



  • @george1421

    yes,
    I did what Sebastian said, and even then nothing, he takes ip and after that mistake " no configuration methods"

    offboard ethernet adapter


  • Moderator

    @zago123 Your issues to me still appear to be a networking infrastructure issue not a fog issue. The most likely cause is spanning tree shutting off the port when it sees the network link “wink” as iPXE takes over.

    Have you confirmed that the mac address displayed c0:4a:08:02:1b:a6 is indeed the mac address of the ethernet adapter?

    Did you do what Sebastian suggested by putting and unmanged switch between the pxe target computer and the building switch?





  • other computer with other error

    0_1519654576459_IMG_20180226_111333655.jpg

    offboard ethernet



  • 0_1519653231488_IMG_20180226_102625355.jpg



  • @george1421 ok i will try


  • Moderator

    @zago123 As sebastian said, plug a dumb (unmanaged) switch between your pxe booting computer and your building switch. Your picture looks like the typical spanning tree issue we see some times. If the unmanaged switch “test” not work then we will have you do the following.

    1. Manually register this computer with fog. Create a host record and name the host, and add the mac address.
    2. Assign the host to an image. The image doesn’t matter because we will do something special next step.
    3. Schedule a deployment to this target computer. Before you press the ok to schedule button, be sure to select the debug check box.
    4. pxe boot the target computer. Since you said debug mode the target computer will ask you to press enter a few times then it will leave you at a linux command prompt. on the target computer.
    5. Key in ip addr show if the network adapter does not have an IP address wait 30 seconds and key in ip addr show again. Post the results in this thread.

    The above test will show us if the network adapter is seen at all by the linux operating system running on the target computer. Once we know where the problem is, we can give you a better answer.

    [edit]Network adapter in mobo is Realtek PHY RTL8201EL [/edit]



  • @sebastian-roth

    I’ll try, the problem only occurs with this motherboard.

    has another problem that is happening, but not frequent, when I go to register a new host, the fog goes straight and will not let me put the host name, can you tell me how to solve?

    sry my english


  • Developer

    @zago123 Try using a dump mini switch to connect between client and your main switch. See if that helps mask the issue.


 

443
Online

41.3k
Users

11.6k
Topics

110.9k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.