Problems with rolling out an Ubuntu image in a VirtualBox on a Win 7 machine



  • Hi everybody,

    today I tried to rollout an image (Ubuntu 16.04) with the fogserver into a Virtualbox on a Win 7 Notebook (Asus P550C).

    I am using VirtualBox 5.2.6.

    When I try to install the image with the fogserver via quick image, the process freezes: 0_1519309709449_Bildschirmfoto vom 2018-02-22 13-14-53.png

    Any idea what could be zthe problem here?

    Thanks a lot!
    Thomas



  • That’s it! I only tried each “Adaptertyp” for the second adapter. After disabling the second adapter (I’ve read somewhere else that two adapters are required…) and changing the first adapter from PCnet… to IntelPro/1000 MT Desktop, the problem was solved.

    Now I was able to install my Ubuntu image via the fogserver in the VirtualBox.

    Thanks a lot!!!


  • Developer

    @bittig Why would you wanna user two adapters?? Please disable the second one and try each and every “Adaptertyp” you have in that list of the first NIC to see if any is working.

    Do I get this right? You have both the FOG server and an Ubuntu client running in Virtualbox on the same machine (Win 7 Notebook - ASUS P550C? And just for the records, what OS/version do you use as FOG server and which version of FOG have you installed?



  • Thank you Sebastian Roth for your help. Unfortunately, I couldn’t manage to solve the problem yet. Here are my network settings:

    0_1519369522677_nw1.PNG
    1_1519369522678_nw2.PNG

    Without the settings of adapter 1, fog didn’t start at all. For adapter 2, I tried all possible adapter types, none didn’t solve the problem.

    Any further ideas? Thank you so much!


  • Developer

    @bittig To me this sounds like a driver/NIC issue. Probably something that can be fixed in the iPXE (or virtualbox) code but would take a lot of effort to come by. Fortunately you have several different NICs to choose from in your VM. Virtualbox -> VM settings -> Network -> Advanced -> Adapater Type… try the PCnet ones for example and see if it works out with one of these.


 

372
Online

41.8k
Users

12.3k
Topics

116.0k
Posts