Storage Node Permission Denied



  • Hi All,
    i have got a single master storage node setup in a remote office along with my main FOG server on my local site.

    When I set of an imaging task for a machine in the remote location which uses the storage node I get a permission denied at the point of applying the image.

    Any suggestions? I assume that the username/password somewhere doesn’t match?

    Thanks


  • Moderator

    @coxm Now that you have a working solution, I’ll tell you a bit easier way to go about this.

    If you know ahead of time you will keep the OS on a thin image and have the /images on a separate disk then before you install fog create the /images directory and mount your image storage disk over /images and finally install FOG. There will be nothing to change post installation. If you see you need to add the disk after fog is install there are a few more steps involved but that’s basically it.

    https://forums.fogproject.org/topic/11048/moving-fog-s-images-files-off-the-root-partition-2017-edition



  • Thanks @george1421 and @Sebastian-Roth with you help and some trial and error it is now working and the remote client try to image via the storage node.


  • Developer

    @coxm Try sudo touch /media/ubuntuadmin/Data/images/.mntcheck and then try deploy again.


  • Moderator

    @coxm While I would not have added the big disk like you did, you still should be able to make it work.

    If you look in the exports file you should see two file share lines. You updated the one for /images but you missed the one for /images/dev.

    FOG captures to /images/dev then moves the file to /images which is read only. This is done to protect the captured image from accidental deletion. You can see the ro vs rw access in the line below, its the first parameter.

    /images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    


  • Felt like the answer was obvious so changed the Fog UI path to match the mount point path.

    So both read Data not Data1.

    This is what we get.

    0_1519214855299_fog14.JPG



  • @george1421
    Hi,
    I have updates the script as you suggested so it now looks like this when doing a showmount -e
    0_1519214424109_fog12.JPG

    but when I run a deply task against a remote machine, that is in the right location group to use the storage node rather than the main fog server it get this.

    0_1519214504619_fog13.JPG

    Notice the difference in path from the showmount output to the path in the image screen grab - this suggest that the path is being pulled from the path entered in the Fog UI, not the mount point.


  • Moderator

    @coxm whelp, if you look at the exports file it should look something like this:

    /images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    

    Knowing that a standard fog server places its images in /images and you placed the images files in /media/ubuntuadmin/Data/Images what might you think you need to update? Also watch the capitalization in the path.



  • @george1421 I do indeed but with loads of options in (), do I need options?

    Also, whats the path to enter as a mount point? /data/images/*?


  • Moderator

    @coxm ok so I have fat fingers. That is the right file. You should see the same shares in there as when you first ran the showmount command.



  • @george1421 said in Storage Node Permission Denied:

    @coxm well that is where your access denied message is coming from.

    As a test, update /etc/exportfs to the real locations. And then run the export -a command. And finally run the showmount command again to ensure the proper directories are shared.

    Sorry, I dont follow. I dont have /etc/exportfs.

    The only thing like it in /etc is /exports


  • Moderator

    @coxm well that is where your access denied message is coming from.

    As a test, update /etc/exportfs to the real locations. And then run the export -a command. And finally run the showmount command again to ensure the proper directories are shared.



  • @george1421
    Hi,

    The “Data” part ofthe file path ist he name of a second disk attached to the ubuntu box. Idea being have a large images disk and smaller system disk.

    Showmount -e 127.0.0.1 results in

    Export List for 127.0.0.1
    /images/dev*
    /images *

    Upon going into those locations they do not hold the fog images found in the path shown in the screen shot.


  • Moderator

    @coxm Well the screen shot tells me that you have something abnormal with this storage node.

    The target computer is trying to mount /media/ubuntuadmin/Data/Images . Is this some type of external storage device on the remote server?

    On the remote storage node please run this command: showmount -e 127.0.0.1 and post the output here.



  • it is a real fog server running on ubuntu configured as storage node only.
    This is the error I am getting, looks more local bases than I first thought.

    0_1519144744953_fog11.JPG


  • Moderator

    Is your storage node a real fog server configured as a storage node, or is this a NAS reconfigured as a storage node?

    I realize we are talking about a remote site, but can you get a screen shot of the actual error so we know what permissions are denied. As long as the target computer can reach a storage node it should deploy.


 

323
Online

41.6k
Users

12.1k
Topics

114.4k
Posts