Capturing Image from Centos/Rhel with single disk resizable wont work whereas ubuntu/kubuntu works



  • Hi,
    I try to capture image from centos7/rhel7 but get an error at “Getting Windows/Linux partitions Count…Failed”, however when i try to capture with debian based OSes e.g ubuntu/kubuntu, it works perfectly fine.
    ![alt text](0_1519041272609_Screenshot (34).png image url)
    P.S capturing centos/rhel images with "Multiple Partition Image Single Disk(non-resizable) works fine


  • Developer

    @irfan4701 @george1421 XFS support has been added years ago. FOG 1.4.4 should be able to properly capture and deploy XFS partitions. Though it cannot shrink it! So you only need to change from XFS to EXT4 if you want resizable images…

    See jdd49’s comment here:

    XFS
    Does not have the ability to shrink period. It can only grow. The only possible solution is to do a file backup using something like xfsdump, then recreate the filesystem. Or make the smallest partition possible when you first install, then grow after imaging.


  • Moderator

    @irfan4701 Interesting because xfs is the default since centos 7 was released. But this is great news, now we have something new to go back to the devs with.



  • @george1421 the issue was due to default partition type that centos was assigning as xfs and not ext4, after changing to ext4 it worked.thanks



  • @george1421 target machine is VM running on virtual box with BIOS.
    Hope this helps.Thanks


  • Moderator

    Tell me a bit more about the target system you are trying to capture from. Is this a virtual machine or physical hardware? Also is this target system in uefi or bios mode? I’d like to see if I can duplicate your setup in my lab.



  • @george1421 i tried with fixed partitions on centos but still i am not getting any output with resizable disk option.attached are the screenshots for lsblk and fog error
    1_1519197369098_Screenshot (38).png 0_1519197369097_Screenshot (37).png

    Am i still doing something wrong with partitioning or i am missing someting else.
    Thanks


  • Moderator

    @irfan4701 I’m going to suspect that with the ubuntu systems its using standard disk partitions. I know that at one time FOG couldn’t resize LVM disks so non-resizable was the only option. I thought the developers were working on that option, but maybe LVM resizing was on the roadmap and not actively being worked on.



  • @george1421 thanks and yeah its LVM on both of the machines(centos/rhel).
    and fog version 1.4.4.
    0_1519044826267_Screenshot (36).png.
    from documentation i can see that LVM is not supported by fog, is there any workaround to work with single disk resizable?Thanks


  • Moderator

    with centos 7 booted, can you post the output of this command
    lsblk ? I’m suspecting that LVM is your disk format.

    Also it would be helpful to know what version of FOG you are using.


 

514
Online

41.9k
Users

12.5k
Topics

117.7k
Posts