Target computer booting from router not fog



  • @WAYNE-WORKMAN @SEBASTIAN-ROTH

    Yes, run fsck /dev/sda1 this problem solution. Thanks !

    My VM is VmWare (Bridged) (Fog Server and client). Client not run from the fog. :(

    Client boot from 192.168.1.1 this router !
    the client machine tries to boot from the router (192.168.1.1) if I set the network configuration to automatic (DHCP). If I configure the network manually (I put the FOG machine as gateway) then it starts from FOG and works fine. How do I start the kernel with FOG and not from the router by putting the client in DHCP mode?

    0_1518371061762_Servidor_Web_SEGURIDAD-2018-02-10-20-16-40.png




  • Moderator

    @orioliz ok, we have two things we need to do to debug this.

    1. what is the output of this command ls -la /tftpboot/undionly.* ?
    2. If the above worked then we will need to capture a pcap of the dhcp dialog that is going on between the pxe booting computer and the dhcp and dnsmasq servers.

    I’n not seeing anything wrong with your dnsmasq config file. (well one small minor things) the config file goes in /etc/dnsmasq.d/ltsp.conf The file you overwrote tells dnsmasq to look in /etc/dnsmasq.d. But no harm no foul.

    Something just hit me. What is the output of this command dnsmasq -v I want to know what version of dnsmasq is installed. The below pxe boot message could be because you have an older version of dnsmasq installed.



  • @sebastian-roth yes, yes. Not boot problem is tftp


  • Developer

    @orioliz Have you gone through the steps outlined in our wiki yet? https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP



  • @george1421 OK, sorry. CLient boot the FOG !! Good !!

    This problem 0_1518381158631_error.png

    Config /etc/dnsmasq.conf is heare:

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,192.168.1.50
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,192.168.1.50
    dhcp-boot=net:UEFI,ipxe.efi,,192.168.1.50
    dhcp-boot=net:UEFI64,ipxe.efi,,192.168.1.50
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=192.168.1.50,proxy```

  • Moderator

    @orioliz [Moderator’s note]: I forked this topic, we like to keep issues isolated so that when others find threads they don’t get confused because the subject doesn’t match the discussion.

    The short answer here is that you need to install dnsmasq on your fog server to supplement the information you are getting from your dhcp server.

    As long as the version of dnsmasq is 2.76 or later then you can use this configuration file for dnsmasq, and once updated will work perfectly.

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,<fog_server_IP>
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI,ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI64,ipxe.efi,,<fog_server_IP>
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=<fog_server_ip>,proxy
    

    Update <fog_server_ip> with the IP address of your FOG server and you will be all set. dnsmasq will run along side your dhcp server but not change what it issues. If you turn off dnsmasq then pxe booting will be disabled again on your network.


 

357
Online

41.8k
Users

12.3k
Topics

116.0k
Posts