Cannot boot to fog without turning off Secure Boot



  • Hello,

    We are using Fog to image a host of HP Machines. 640’s, 840’s, desktops, laptops, etc…

    We cannot seem to get the machines to boot to the Fog menu when Secure Boot is turned on.

    The machine boots, receives an IP address, downloads the NBP file, then jumps right into bios with an HP Error Screen that reads “Selected boot image did not authenticate”.

    Of course when we google this, it says to switch to legacy. Well we just converted our DHCP over to 2012 Server to hopefully get away from Legacy and start using EFI.

    Anybody have any ideas on what we might need to do here to get this to work? We have had a hell of a time trying to get UEFI boots working.



  • FYI, while deploying / capturing you are forced to disable secure boot because the kernels are not signed, after deployment / capturing you can enable secure boot if you like (uefi only).

    Regards X23



  • @caw001 You don’t have to go back to legacy boot, you just need to turn off secure boot. Most system’s firmware allows you to do this.


 

568
Online

5.4k
Users

12.6k
Topics

118.9k
Posts