Lenovo IdeaCentre Stick 300 - unable to UEFI USB Boot



  • Hello

    In my company I have several Lenovo IdeaCentre Stick 300 and I need to create and deploy images on them.

    To connect the USB stick, the USB ethernet adapter and a keyboard I’m using a simple USB Hub.

    I’m able to start the boot process via USB, following the instructions available here but the boot process crashes after listing the Features (DNS, HTTP etc) - the very beginning of the proccess.

    How can I debug that? Or most importantly, there is any problem with this hardware and/or hardware setup?

    Thanks



  • After all it was my basically my fault.

    The IPXE UEFI USB Boot did not work…

    So, following the instructions provided by George, i decided to use the FOS image.

    I built one, using these instructions: https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image/4

    One caveat: The PC that I used to build the image is a Fedora 27, so I used the CentOS 7 script and i added the following line to create the 32 bits setting for grub2:

    grub2-install --removable --no-nvram --efi-directory=/mnt --boot-directory=/mnt/boot --target=i386-efi

    After that, I got the error reported here, but it was because I did not have started a task on the server. After I scheduled a capture task on the FOG Server, everything worked smootly.


  • Moderator

    @seidler Ah the null error. This one is one of the caveats of USB booting into FOS. You have to schedule a capture or deploy first on the FOG server then boot the USB version of FOS. I know the error message is not clear, but what it means is that the FOG server has nothing (Null) for you to do. Schedule a capture/deploy task first then try it again. This caveat IS documented in the thread I linked to.



  • I tried both ways, the hard and the easy way.
    As oriented, I was able to boot using the FOS Image. But faced problems with networking. Like you correctly said, it was related with STP, by disabling it, it was possible to get an IP on the first try, but another problem happened (attached images).

    This my grub.cfg configuration:
    set myfogip=192.168.11.171

    My Fog server has selinux in Permissive mode and the firewall is disabled.
    I’m able to ping the server and the compatibility test passed.
    And I was able to make a Full Registration and Inventory the host. When I try to create a image the problem appears.

    Thank you for your help, George.

    0_1518012358136_IMG_20180207_115341.jpg
    0_1518012367945_IMG_20180207_115406.jpg
    0_1518012400471_IMG_20180207_115218.jpg


  • Moderator

    The linked wiki document contains 2 routes which path did you try? Since these are uefi systems, I would attempt the easy route using ipxe.efi as the source boot file.

    If iPXE continues to crash there is an alternate path you can try by booting directly into FOS and bypassing iPXE. This is not as flexible as the iPXE booting but it does work in most cases. https://forums.fogproject.org/topic/7727/building-usb-booting-fos-image Read all of the parts they are a bit mixed up in the thread because the way the forums work. Make sure you are aware of all of the caveats with going this route (they are listed in the thread). Also check the forum tool tray for the chat bubble, I’m going to send you some additional info.


 

319
Online

41.6k
Users

12.1k
Topics

114.4k
Posts